1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Macros / Captcha problem

Discussion in 'Black Hat SEO Tools' started by Timbo, Jan 31, 2010.

  1. Timbo

    Timbo Regular Member

    Joined:
    May 13, 2008
    Messages:
    235
    Likes Received:
    35
    Home Page:
    Cant seem to save a captcha image using imacoros. It will save but it's never the one on the page. Do they have a system in place to auto change them when you are trying to save them? The exact page is here:

    http://chinasalthaolong.com/submit.php


    BTW I am deleting the old saved one before saving the new one.
     
  2. antsaoo

    antsaoo Supreme Member

    Joined:
    Oct 1, 2008
    Messages:
    1,291
    Likes Received:
    637
    The problem pretty much is When you going to saving the image you make new connection on the server which triggers new catchpa image. This is atleast with firefox. With it you can do save as without that problem. Maybe you could take the image from temporary files or so . It has to save it somewhere to show it to you ;)
     
  3. TheGoat

    TheGoat Registered Member

    Joined:
    Oct 1, 2009
    Messages:
    70
    Likes Received:
    85
    I just had this exact problem today while trying to efficiently incorporate decaptcher into an autoit script I wrote. The problem for me was that the captcha was being stored in the firefox memory cache and not on the hard drive.

    I had to use the this.internalSave() function as referenced by chrome://global/content/contentAreaUtils.js

    Was easy enough to implement with autoIt, but imacros? Ugh.. good luck.