1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Link indexing issue? (Links dont seem to be indexing)

Discussion in 'Black Hat SEO' started by excessive34, Feb 13, 2013.

  1. excessive34

    excessive34 Junior Member

    Joined:
    Apr 1, 2011
    Messages:
    111
    Likes Received:
    6
    I have a well established site (2 years old, PA 40, PR2).

    Over the past month and a half, i've purchased a few backlink services off BHW. (Done this since the site was created)


    However, I'm noticing that none of the links from these services are getting indexed, even when the suppliers are submitting them to indexing services. It's making me weary.

    Is there any reason this could be happening? Or is it possible that they just arent indexed yet? (Over a month)

    I got the reports for the services so I know they were completed.

    I also am not banned from google or anything like that.
     
  2. twistedtrick

    twistedtrick Power Member

    Joined:
    Aug 21, 2009
    Messages:
    654
    Likes Received:
    376
    Location:
    United States
    What service are you using to check if the links are indexed? I prefer MajesticSEO because I feel like their crawler does a very speedy job.
     
  3. excessive34

    excessive34 Junior Member

    Joined:
    Apr 1, 2011
    Messages:
    111
    Likes Received:
    6
    Yep, been using Majestic also.

    Its frustrating because I dont know what the packages ive purchased have done for me since the links arent getting indexed. Im kind of stuck atm lol