1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Issue with wordpress set up, please help!

Discussion in 'Web Design' started by mdsurf, Aug 30, 2012.

  1. mdsurf

    mdsurf Senior Member

    Joined:
    Jun 16, 2011
    Messages:
    990
    Likes Received:
    279
    Location:
    Las Vegas
    Hello everyone,

    I set up a new wordpress theme on one of my domains and am having issues with it. for some reason everything works fine when i type in www.mydomain.com but without the www. i get this error:

    Warning: Cannot modify header information - headers already sent by (output started at /home/****/public_html/mydomain.com/index.php:2) in /home/****/public_html/mydomain.com/wp-includes/pluggable.php on line 881

    The reason for the *** is its just to protect a path. But other then that I dont know why this is happening, can someone please help. I've tried disabling all the plugins and that didn't help at all!
     
  2. seoreports

    seoreports Junior Member

    Joined:
    Aug 26, 2012
    Messages:
    151
    Likes Received:
    34
    did you install any plugins? Disable all of them and see if you still get the error. You could also try re-installing. Just going from www to sans-www isn't going to break wordpress.
     
  3. bobbylove321

    bobbylove321 BANNED BANNED

    Joined:
    Nov 8, 2008
    Messages:
    1,987
    Likes Received:
    2,198
    It's the new theme.

    Replace it.
     
  4. ice41

    ice41 Power Member

    Joined:
    Aug 18, 2012
    Messages:
    783
    Likes Received:
    248
    Occupation:
    Web Designer
    Location:
    Land of Pineapples
    Check your .htaccess, you can verify the culprit.
     
  5. mdsurf

    mdsurf Senior Member

    Joined:
    Jun 16, 2011
    Messages:
    990
    Likes Received:
    279
    Location:
    Las Vegas
    So I went under settings and changed the site url from http://www.mydomain.com to http://mydomain.com and the problem has reversed itself, it seems that which ever option i choose to set it on the oposite once causes these problems
     
  6. jazzc

    jazzc Moderator Staff Member Moderator Jr. VIP

    Joined:
    Jan 27, 2009
    Messages:
    2,468
    Likes Received:
    10,148
    If you can't pinpoint it, disable the warning messages. In your htaccess file, put this
    Code:
    php_flag display_startup_errors off
    php_flag display_errors off
    php_flag html_errors off
    php_value docref_root 0
    php_value docref_ext 0
    
     
  7. Blackberry_11

    Blackberry_11 Regular Member

    Joined:
    Apr 17, 2011
    Messages:
    266
    Likes Received:
    19
    There must be some plugin that is making it work like this. If you have proper idea about wordpress then you can do that on your own.
     
  8. ice41

    ice41 Power Member

    Joined:
    Aug 18, 2012
    Messages:
    783
    Likes Received:
    248
    Occupation:
    Web Designer
    Location:
    Land of Pineapples
    add this on your .htaccess
    Code:
    #RewriteCond %{HTTP_HOST} ^domain(dot)coxm
    #RewriteRule (.*) hxxp :// www(dot)domain(dot)coxm/$1 [R=301,L]
    
    Just fix the formatting, I can't post links :(
     
  9. RossK

    RossK Newbie

    Joined:
    Sep 24, 2012
    Messages:
    12
    Likes Received:
    1
    Occupation:
    eBay seller
    Location:
    Scotland
    You should get a theme from ThemeForest.