1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Installing Kloxo 6.1.x official like good old days (32 bit).

Discussion in 'General Programming Chat' started by colorfull, Mar 27, 2017.

  1. colorfull

    colorfull Newbie

    Joined:
    Mar 11, 2015
    Messages:
    49
    Likes Received:
    1
    I removed kloxoMR since I found out it is made on purpose to not being compatible with PHP 5.2.17,yes it is supposed that it has a fancy php admin where you can switch between php versions but when you switch to 5.2 it cracks out ,so you can call it what you want but i removed it and try to go ahead without panel and first it was hard but from not having nothing I ended up having apache running well and I could finally see php files something I could never see on kloxoMR since it always brought error 500.

    Well Im gaining knowledge into the mysql thang but since Ive heard that most everybody has problems with it and problems with the password then Is not Im afraid or anything but I got the idea of installing the old kloxo 32 bits yes the official one,so I found it uploaded to my server and tried to install it but it gives me this errors


    Notice: Undefined variable: return_value in /kloxo-master/kloxo-install/kloxo-installer.php on line 100


    Notice: Undefined variable: return_value in /kloxo-master/kloxo-install/kloxo-install/kloxo-installer.php on line 100

    Warning: system() has been disabled for security reasons in /kloxo-master/kloxo-install/kloxo-install/kloxo-installer.php on line 100
    YUM Gave Error... Trying Again...
    Try again? [y/N]:
    - EXIT: Fix the problem and install Kloxo again.
     
  2. colorfull

    colorfull Newbie

    Joined:
    Mar 11, 2015
    Messages:
    49
    Likes Received:
    1
    I thaught some of the errors was because the machine I was into was centos 5 x86_64 and at some ways it was thrue since I tried install it at other machine with centos 5 x86 and installation ran beautifully

    Installing as "root" OK
    Operating System supported OK
    SELinux disabled OK
    Yum installed OK

    Ready to begin Kloxo (master) install.


    Note some file downloads may not show a progress bar so please, do not interrupt the process.
    When it's finished, you will be presented with a welcome message and further instructions.


    Press any key to continue ...lLoaded plugins: fastestmirror
    Determining fastest mirrors
    * base: mirrors.advancedhosters.com
    * updates: mirrors.lga7.us.voxel.net
    * addons: mirror.cogentco.com
    * extras: mirror.rackspace.com
    base | 1.1 kB 00:00
    primary.xml.gz | 996 kB 00:00
    base 2791/2791
    updates | 1.9 kB 00:00
    primary.sqlite.bz2 | 904 kB 00:00
    addons | 1.9 kB 00:00
    primary.sqlite.bz2 | 1.1 kB 00:00
    extras | 2.1 kB 00:00
    primary.sqlite.bz2 | 164 kB 00:00
    Setting up Install Process
    Parsing package install arguments
    Package unzip-5.52-3.el5.i386 already installed and latest version
    Resolving Dependencies
    --> Running transaction check
    ---> Package php-mysql.i386 0:5.1.6-45.el5_11 set to be updated
    --> Processing Dependency: php-common = 5.1.6-45.el5_11 for package: php-mysql
    --> Processing Dependency: libmysqlclient.so.15(libmysqlclient_15) for package: php-mysql
    --> Processing Dependency: libmysqlclient.so.15 for package: php-mysql
    --> Processing Dependency: php-pdo for package: php-mysql
    ---> Package zip.i386 0:2.31-2.el5 set to be updated
    ---> Package php.i386 0:5.1.6-45.el5_11 set to be updated
    --> Processing Dependency: php-cli = 5.1.6-45.el5_11 for package: php
    --> Processing Dependency: libgmp.so.3 for package: php
    ---> Package wget.i386 0:1.11.4-3.el5_8.2 set to be updated
    --> Running transaction check
    ---> Package gmp.i386 0:4.1.4-10.el5 set to be updated
    ---> Package php-cli.i386 0:5.1.6-45.el5_11 set to be updated
    ---> Package mysql.i386 0:5.0.95-5.el5_9 set to be updated
    --> Processing Dependency: perl(DBI) for package: mysql
    ---> Package php-pdo.i386 0:5.1.6-45.el5_11 set to be updated
    ---> Package php-common.i386 0:5.1.6-45.el5_11 set to be updated
    --> Running transaction check
    ---> Package perl-DBI.i386 0:1.52-2.el5 set to be updated
    --> Finished Dependency Resolution

    Dependencies Resolved

    ================================================================================
    Package Arch Version Repository Size
    ================================================================================
    Installing:
    php i386 5.1.6-45.el5_11 updates 2.3 M
    php-mysql i386 5.1.6-45.el5_11 updates 88 k
    zip i386 2.31-2.el5 base 127 k
    Updating:
    wget i386 1.11.4-3.el5_8.2 base 582 k
    Installing for dependencies:
    gmp i386 4.1.4-10.el5 base 664 k
    mysql i386 5.0.95-5.el5_9 base 4.9 M
    perl-DBI i386 1.52-2.el5 base 600 k
    php-cli i386 5.1.6-45.el5_11 updates 2.1 M
    php-common i386 5.1.6-45.el5_11 updates 155 k
    php-pdo i386 5.1.6-45.el5_11 updates 67 k

    Transaction Summary
    ================================================================================
    Install 9 Package(s)
    Update 1 Package(s)
    Remove 0 Package(s)

    Total download size: 12 M
    Downloading Packages:
    (1/10): php-pdo-5.1.6-45.el5_11.i386.rpm | 67 kB 00:00
    (2/10): php-mysql-5.1.6-45.el5_11.i386.rpm | 88 kB 00:00
    (3/10): zip-2.31-2.el5.i386.rpm | 127 kB 00:00
    (4/10): php-common-5.1.6-45.el5_11.i386.rpm | 155 kB 00:00
    (5/10): wget-1.11.4-3.el5_8.2.i386.rpm | 582 kB 00:00
    (6/10): perl-DBI-1.52-2.el5.i386.rpm | 600 kB 00:00
    (7/10): gmp-4.1.4-10.el5.i386.rpm | 664 kB 00:00
    (8/10): php-cli-5.1.6-45.el5_11.i386.rpm | 2.1 MB 00:00
    (9/10): php-5.1.6-45.el5_11.i386.rpm | 2.3 MB 00:00
    (10/10): mysql-5.0.95-5.el5_9.i386.rpm | 4.9 MB 00:00
    --------------------------------------------------------------------------------
    Total 7.9 MB/s | 12 MB 00:01
    Running rpm_check_debug
    Running Transaction Test
    Finished Transaction Test
    Transaction Test Succeeded
    Running Transaction
    Installing : php-common [ 1/11]
    Installing : gmp [ 2/11]
    Installing : php-cli [ 3/11]
    Installing : php-pdo [ 4/11]
    Installing : perl-DBI [ 5/11]
    Installing : mysql [ 6/11]
    Installing : php-mysql [ 7/11]
    Installing : zip [ 8/11]
    Updating : wget [ 9/11]
    Installing : php [10/11]
    Cleanup : wget [11/11]

    Installed: php.i386 0:5.1.6-45.el5_11 php-mysql.i386 0:5.1.6-45.el5_11 zip.i386 0:2.31-2.el5
    Dependency Installed: gmp.i386 0:4.1.4-10.el5 mysql.i386 0:5.0.95-5.el5_9 perl-DBI.i386 0:1.52-2.el5 php-cli.i386 0:5.1.6-45.el5_11 php-common.i386 0:5.1.6-45.el5_11 php-pdo.i386 0:5.1.6-45.el5_11
    Updated: wget.i386 0:1.11.4-3.el5_8.2
    Complete!
    --2017-03-29 03:51:27-- http://download.lxcenter.org/download/kloxo-install.zip
    Resolving download.lxcenter.org... 69.172.201.153
    Connecting to download.lxcenter.org|69.172.201.153|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: unspecified [text/html]
    Saving to: `kloxo-install.zip'

    [ <=> ] 1,556 --.-K/s in 0s

    2017-03-29 03:51:58 (149 MB/s) - `kloxo-install.zip' saved [1556]

    [kloxo-install.zip]
    End-of-central-directory signature not found. Either this file is not
    a zipfile, or it constitutes one disk of a multi-part archive. In the
    latter case the central directory and zipfile comment will be found on
    the last disk(s) of this archive.
    unzip: cannot find zipfile directory in one of kloxo-install.zip or
    kloxo-install.zip.zip, and cannot find kloxo-install.zip.ZIP, period.
    ./kloxo-installer.sh: line 203: cd: kloxo-install: No such file or directory
    Kloxo is using AGPL-V3.0 License, do you agree with the terms? [y/N]: y
    Installing Kloxo = YES

    InstallApp: PHP Applications like PHPBB, WordPress, Joomla etc
    When you choose Yes, be aware of downloading about 350Mb of data!
    Do you want to install the InstallAPP sotfware? [y/N]: y
    Installing InstallApp = YES



    Well ,it all seemed marvelous as I told you but then I got this errors

    Adding System users and groups (nouser, nogroup and lxlabs, lxlabs)
    Installing LxCenter yum repository for updates
    Removing packages sendmail sendmail-cf sendmail-doc sendmail-devel exim vsftpd postfix vpopmail qmail kloxo-core-php lxphp lxzend pure-ftpd imap...
    Installing packages php-mbstring php-mysql which gcc-c++ php-imap php-pear php-devel lxlighttpd httpd mod_ssl zip unzip kloxo-core-php mysql mysql-server curl autoconf automake libtool bogofilter gcc cpp openssl pure-ftpd yum-protectbase...
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: mirrors.advancedhosters.com
    * updates: mirrors.lga7.us.voxel.net
    * addons: mirror.cogentco.com
    * extras: mirror.rackspace.com
    http://download.lxcenter.org/download/update/centos-5/i386/repodata/repomd.xml: [Errno -1] Error importing repomd.xml for lxcenter-updates: Damaged repomd.xml file
    Trying other mirror.
    Error: Cannot retrieve repository metadata (repomd.xml) for repository: lxcenter-updates. Please verify its path and try again
    YUM Gave Error... Trying Again...
    Try again? [y/N]: ^C


    Any support from a knowledgeable person would be so appreciated
     
    Last edited: Mar 29, 2017
  3. ziplack

    ziplack Supreme Member

    Joined:
    Feb 18, 2010
    Messages:
    1,306
    Likes Received:
    673
    Location:
    BHW
    try using webmin/virtualmin
    its way better than kloxo
     
  4. colorfull

    colorfull Newbie

    Joined:
    Mar 11, 2015
    Messages:
    49
    Likes Received:
    1
    Hi this is my improvement by now on installation

    Installing as "root" OK
    Operating System supported OK
    SELinux disabled OK
    Yum installed OK

    Ready to begin Kloxo (master) install.


    Note some file downloads may not show a progress bar so please, do not interrupt the process.
    When it's finished, you will be presented with a welcome message and further instructions.


    Press any key to continue ...
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: centos.mirror.nac.net
    * extras: mirror.vtti.vt.edu
    * updates: mirrors.evowise.com
    Setting up Install Process
    Package php-5.1.6-45.el5_11.i386 already installed and latest version
    Package php-mysql-5.1.6-45.el5_11.i386 already installed and latest version
    Package wget-1.11.4-3.el5_8.2.i386 already installed and latest version
    Package zip-2.31-2.el5.i386 already installed and latest version
    Package unzip-5.52-3.el5.i386 already installed and latest version
    Nothing to do

    Programmers wanted