iMacros script not saving captcha image

Discussion in 'Black Hat SEO' started by robibrk, Nov 13, 2013.

  1. robibrk

    robibrk Regular Member

    Joined:
    Aug 23, 2009
    Messages:
    321
    Likes Received:
    121
    Hi, i want to integrate captcha solving to my iMacro code, all fine no errors. But, the captcha image is not saving. Please can someone look at my code?

    Code:
    FILEDELETE NAME=d:\pic.jpg
    ONDOWNLOAD FOLDER=d:\ FILE=pic.jpg
    TAG POS=1 TYPE=IMG ATTR=HREF:http://www.google.com/recaptcha/api/image?c=*CONTENT=EVENT:SAVEITEM
    TAB OPEN
    TAB T=2
    URL GOTO=http://beatcaptchas.com/captcha.php
    TAG POS=1 TYPE=INPUT:TEXT FORM=ACTION:upload.php ATTR=ID:key CONTENT=MYKEY
    TAG POS=1 TYPE=INPUT:FILE FORM=ACTION:upload.php ATTR=NAME:file CONTENT=d:\pic.jpg
    WAIT SECONDS=3
    TAG POS=1 TYPE=INPUT:SUBMIT FORM=ACTION:upload.php ATTR=NAME:submit
    TAG POS=1 TYPE=BODY ATTR=TXT:* EXTRACT=TXT
    SET !VAR1 {{!EXTRACT}} 
    TAB T=1
    TAG POS=1 TYPE=INPUT:TEXT FORM=NAME:regFormBody ATTR=ID:captcha CONTENT={{!var1}}
    WAIT SECONDS=3
    
     
  2. robibrk

    robibrk Regular Member

    Joined:
    Aug 23, 2009
    Messages:
    321
    Likes Received:
    121
    Come on guys, someone must know. I have wasted several hours to find a solution on web, there is nothing more what can i do. Rechecked the code again and again, but the captcha image is not saving to my HDD, thats the reason for non solving. them.
     
  3. robibrk

    robibrk Regular Member

    Joined:
    Aug 23, 2009
    Messages:
    321
    Likes Received:
    121
    I have contacted beatcaptchas support (my captcha provider) and after 2 emails i got this response from the admin:

    They are unprofessional. They not even checked, that i am his customer.

    Hence please anyone can help me out to find what is wrong with my code.
     
  4. robibrk

    robibrk Regular Member

    Joined:
    Aug 23, 2009
    Messages:
    321
    Likes Received:
    121
    I have fixed all the stuff, only the captcha text is not showing up in captcha input. Anyone?

    Code:
    VERSION BUILD=8300326 RECORDER=FX
    SET !ERRORIGNORE YES
    SET !TIMEOUT_TAG 1
    SET !TIMEOUT_STEP 1
    SET !TIMEOUT_PAGE 30
    SET !REPLAYSPEED FAST
    FILEDELETE NAME=d:\pic.jpg
    ONDOWNLOAD FOLDER=d:\ FILE=pic.jpg
    TAG POS=1 TYPE=IMG ATTR=HREF:*captcha* CONTENT=EVENT:SAVEPICTUREAS
    TAB OPEN
    TAB T=2
    SET !EXTRACT_TEST_POPUP NO
    URL GOTO=http://beatcaptchas.com/captcha.php
    TAG POS=1 TYPE=INPUT:TEXT FORM=ACTION:upload.php ATTR=ID:key CONTENT=MYKEY
    TAG POS=1 TYPE=INPUT:FILE FORM=ACTION:upload.php ATTR=NAME:file CONTENT=d:\pic.jpg
    TAG POS=1 TYPE=INPUT:SUBMIT FORM=ACTION:upload.php ATTR=NAME:submit
    TAG POS=1 TYPE=BODY ATTR=TXT:* EXTRACT=TXT
    SET !VAR1 {{!EXTRACT}}
    TAB CLOSE
    TAG POS=1 TYPE=INPUT:TEXT FORM=NAME:regFormBody ATTR=ID:captcha CONTENT={{!VAR1}}
    WAIT SECONDS=3
     
  5. tammy23

    tammy23 Newbie

    Joined:
    Aug 18, 2013
    Messages:
    10
    Likes Received:
    1
    Did you ever find an answer? I'm looking for the same thing?