iMacros problem

Discussion in 'Black Hat SEO' started by Satyren, Jun 11, 2010.

  1. Satyren

    Satyren Power Member

    Joined:
    Nov 29, 2009
    Messages:
    501
    Likes Received:
    599
    Location:
    EU
    Hi.

    I'm setting up a commentspammer for a community with iMacros (just the FF addon).

    The problem is that the macro is only valid once, because the url's changes after each profilepage i enter. ("RuntimeError: element TEXTAREA specified by ID:commentTextarea was not found, line 5")

    I want iMacros to ignore the fact that the url is changing. Is this possible?

    http://site.com/profile.html?id=<random>&profilename=<random>
     
  2. heavyweight

    heavyweight Junior Member Premium Member

    Joined:
    Aug 10, 2009
    Messages:
    131
    Likes Received:
    65
    Yes it is

    You can use * to replace any characters
    Becomes:
    http://site.com/profile.html?id=*&profilename=*
     
  3. movieman32

    movieman32 Regular Member

    Joined:
    Aug 6, 2008
    Messages:
    371
    Likes Received:
    346
    If you're willing to trust me a little and share the community URL, I'll look at fixing the problem. You can pm if you prefer.
     
  4. Satyren

    Satyren Power Member

    Joined:
    Nov 29, 2009
    Messages:
    501
    Likes Received:
    599
    Location:
    EU
    Problem solved! Astericks was the solution. Thanks.

    Another problem occured though. The "send"-button is javascript, so it has no URL. How can I get iMacros to recognize the button?
     
  5. heavyweight

    heavyweight Junior Member Premium Member

    Joined:
    Aug 10, 2009
    Messages:
    131
    Likes Received:
    65
    It doesn't matter.
    Press record marco and click on that button. Imacros will generate the code for that button and you can use that code.