1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Imacros colums

Discussion in 'General Scripting Chat' started by damianvivat1, Aug 28, 2013.

  1. damianvivat1

    damianvivat1 Newbie

    Joined:
    Aug 24, 2013
    Messages:
    11
    Likes Received:
    0
    My script look like:

    SET !DATASOURCE test.csv
    SET !DATASOURCE_COLUMNS 2
    SET !LOOP 1
    SET !DATASOURCE_LINE {{!LOOP}}
    TAG POS=1 TYPE=INPUT:TEXT FORM=NAME:createaccount ATTR=ID:LastName CONTENT={{!COL1}}
    TAG POS=1 TYPE=INPUT:TEXT FORM=NAME:createaccount ATTR=ID:EmailAddress CONTENT={{!COL2}}


    And my test.csv looks like:
    fujx.png

    And when i start my macro, in "LastName" i have "1;a" not only "1".. What i doing wrong ?
     
  2. Henggybf5

    Henggybf5 Newbie

    Joined:
    Mar 1, 2013
    Messages:
    3
    Likes Received:
    3
    I think you need , not ; to separate fields
     
  3. HoNeYBiRD

    HoNeYBiRD Jr. VIP Jr. VIP

    Joined:
    May 1, 2009
    Messages:
    5,875
    Likes Received:
    7,115
    Gender:
    Male
    Occupation:
    Geographer, Tourism Manager
    Location:
    Ghosted
    yea, that's tricky a bit :), i remember having the same problem, unfortunately i don't remember the exact solution, but one thing is sure, you need to make the columns in your .csv comma separated like this:
    HTML:
    1,a
    2,b
    3,c
    you can try doing it in excel or with notepad and saving the document as .csv, i'm not 100% sure, but i remember doing it with notepad because if i did it in excel it didn't work for some reason

    try it, it should work
     
  4. damianvivat1

    damianvivat1 Newbie

    Joined:
    Aug 24, 2013
    Messages:
    11
    Likes Received:
    0
    Hmm.. i know where is the problem..

    new column in excel create ";" separate, not ",".. How to change that ?