1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How to add nameservers to GoDaddy?

Discussion in 'Domain Names & Parking' started by pxoxrxn, Mar 31, 2014.

  1. pxoxrxn

    pxoxrxn Supreme Member

    Joined:
    Dec 21, 2011
    Messages:
    1,397
    Likes Received:
    2,066
    Hi, I am using Kloxo on a CentOS server and I created a DNS template with the nameservers ns1.mydomain.com and ns2.mydomain.com

    Where do I put this into GoDaddy? I clicked on Nameservers under settings and tried to add them, but it says You must enter a registered nameserver.

    WTF does that mean? I also tried to put them in the A record but it just points to the server an the server doesn't know which domain its trying to access.
     
  2. b1step-ahead

    b1step-ahead Power Member

    Joined:
    Nov 15, 2010
    Messages:
    732
    Likes Received:
    298
    not 100% if this will help but try using caps. I ran into the same thing and just kept trying.
     
  3. heartnet02

    heartnet02 Power Member

    Joined:
    Aug 27, 2012
    Messages:
    533
    Likes Received:
    95
    Home Page:
    Go to your domain, access name servers. Then change the current one with your new one. Make sure there are no spaces before or after the ns1.mydomain.com .
     
  4. pxoxrxn

    pxoxrxn Supreme Member

    Joined:
    Dec 21, 2011
    Messages:
    1,397
    Likes Received:
    2,066
    Yup, it doesn't work. It says You must enter a registered nameserver
     
  5. Mnet17

    Mnet17 Junior Member

    Joined:
    Feb 28, 2013
    Messages:
    192
    Likes Received:
    135
    Location:
    Philadelphia
    Did you create a host file for your mydomain.com?

    You need to create host file for it to work.
     
  6. pxoxrxn

    pxoxrxn Supreme Member

    Joined:
    Dec 21, 2011
    Messages:
    1,397
    Likes Received:
    2,066
    Yeah, there is already one there. What do I need to put into the host file?
     
  7. pxoxrxn

    pxoxrxn Supreme Member

    Joined:
    Dec 21, 2011
    Messages:
    1,397
    Likes Received:
    2,066
    Never mind people, you can stop stressing out now. Turns out I had it right all along, just needed an A record but I needed to restart the server. I've never had to do that before but it worked.

    Thanks for all ya'll help anyway.