1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

(HELP) wordpress question?

Discussion in 'Blogging' started by T2tkid, Jun 17, 2011.

  1. T2tkid

    T2tkid Jr. VIP Jr. VIP Premium Member

    Joined:
    Oct 13, 2010
    Messages:
    3,193
    Likes Received:
    1,459
    Can this be solved?
    Parse error : syntax error, unexpected T_STRING, expecting'('in /home/public_html/ site.com /wp-content/themes/functions.php on line 23

    i have tried everything i just can't access my site and i can't fix it.
    Thanks for your help.
     
  2. wadboram

    wadboram Newbie

    Joined:
    Oct 7, 2010
    Messages:
    34
    Likes Received:
    8
    Location:
    Egypt
    Home Page:
    Hi dude,

    Just go to h**p://wordpress.org/support/
    post your questions and you'll get many WP PROs there to help
     
  3. regmant

    regmant Regular Member

    Joined:
    Jan 28, 2011
    Messages:
    337
    Likes Received:
    122
    Occupation:
    Web Developer
    Location:
    UK
    Sorry if I'm stating the obvious, but the issue is a syntax error in your functions file. You will need to FTP and download the file to fix it.

    If you don't know how, then I can probably do it for you (I'm a web developer by trade), so shoot me a PM if you want me to take a look.
     
    • Thanks Thanks x 1
  4. oxonbeef

    oxonbeef BANNED BANNED

    Joined:
    Jan 4, 2009
    Messages:
    2,242
    Likes Received:
    7,872
    Go to file manager, download (public_html/ site.com /wp-content/themes/functions.php)
    Look on line 23 for the error, fix it, upload and overwrite.
    Or look in the theme for that file fix it from there and upload and overwrite.
    Some themes just need to be FTP'd and break when using WP.
     
    • Thanks Thanks x 2
  5. yesrams

    yesrams Regular Member

    Joined:
    Dec 16, 2009
    Messages:
    354
    Likes Received:
    75
    Location:
    @BHW
    login to you cpanel/file manager.....(or) use ftp
    go to wp-content/themes/
    Delete that Theme you recently installed....
    use wordpress Default Theme as your current theme......
    now check. if it is working perfecly ....
    Again install that new theme...
     
    • Thanks Thanks x 1
  6. T2tkid

    T2tkid Jr. VIP Jr. VIP Premium Member

    Joined:
    Oct 13, 2010
    Messages:
    3,193
    Likes Received:
    1,459
  7. madoctopus

    madoctopus Supreme Member

    Joined:
    Apr 4, 2010
    Messages:
    1,249
    Likes Received:
    3,498
    Occupation:
    Full time IM
    paste the code from lines 15 to 30 here and i'll fix it for u
     
    • Thanks Thanks x 1
  8. T2tkid

    T2tkid Jr. VIP Jr. VIP Premium Member

    Joined:
    Oct 13, 2010
    Messages:
    3,193
    Likes Received:
    1,459
    Got this fix by regmant.
    Thanks a lot.