1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

help with xampp install

Discussion in 'PHP & Perl' started by rob1977, Nov 1, 2013.

  1. rob1977

    rob1977 Power Member

    Joined:
    Mar 25, 2013
    Messages:
    773
    Likes Received:
    666
    Hi all,

    I have been trying to install xampp on a 32Gig fob in the hope it would function as a portable development environment.

    I got it installed with PHP MySQL and perl (for a giggle).

    Opened the control panel (ok)

    Started both apache and MySQL (all ok)

    Attempted to access the apache admin area.

    Browser opened.
    Attempted to access local host. (No Joy)

    I tried a different browser (No Joy)

    I moved and reinstalled it on desktop to see if fob was too slow and exactly the same happened.

    No access to local host.

    I thought about both antivirus and admin permissions, which I changed. No Joy.

    It is a Windows os.

    Any ideas? Or has anyone done this and got it to work?
     
  2. bytzu

    bytzu Registered Member

    Joined:
    Jun 30, 2011
    Messages:
    96
    Likes Received:
    137
    Hello,

    is apache started? it works on port 80 so you might have other applications using this port such as akype.
     
    • Thanks Thanks x 1
  3. cchinta

    cchinta Newbie

    Joined:
    Nov 14, 2013
    Messages:
    24
    Likes Received:
    3
    i have also the same problem ! i was close the skype but still ..
     
    • Thanks Thanks x 1
  4. Schvamp

    Schvamp Power Member

    Joined:
    Feb 13, 2012
    Messages:
    684
    Likes Received:
    549
    Location:
    Hogwarts
    Close (or edit in the settings) all programs that may be using port 80 ie skype. Or change the apache port.
     
    • Thanks Thanks x 1
    Last edited: Nov 16, 2013
  5. MafiaBoss

    MafiaBoss Elite Member

    Joined:
    May 5, 2012
    Messages:
    1,522
    Likes Received:
    1,031
    Occupation:
    Currently Un-Occupied
    Location:
    In granny's Basement
    Home Page:
    change the port, i think some application will be using the port require for xampp, 80 or something.
     
    • Thanks Thanks x 1
  6. JennieP

    JennieP Newbie

    Joined:
    Sep 15, 2013
    Messages:
    37
    Likes Received:
    9
    See if you have windows firewall on.
     
    • Thanks Thanks x 1
  7. Dhruv11

    Dhruv11 Newbie

    Joined:
    Oct 21, 2012
    Messages:
    33
    Likes Received:
    12
    Exactly !! Skype, IIS are common culpritsIn this case u will have to configure ur apache to run on port other than 80.
     
    • Thanks Thanks x 1
  8. rob1977

    rob1977 Power Member

    Joined:
    Mar 25, 2013
    Messages:
    773
    Likes Received:
    666
    Thank you all for your replies. I have not been able to reply sooner because of the ddos.

    I will try and make the adjustments. Failing that I may look at another stack instead.