1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help I dont know what I did wrong or how to fix it.

Discussion in 'White Hat SEO' started by SpongeSaga, Jul 23, 2009.

  1. SpongeSaga

    SpongeSaga Newbie

    Joined:
    May 3, 2009
    Messages:
    6
    Likes Received:
    0
    I use SEO Quake plug in and today I noticed my Google index # dropped from a hundred to 24. For the last few days my post are not getting index. I also noticed today when i try to bookmark my new posts it comes up blank. It will say "not a valid Url" or "site has been blocked" what could have caused this? How did I lose 75 index's?
     
  2. keinehabe

    keinehabe Supreme Member

    Joined:
    Nov 4, 2008
    Messages:
    1,207
    Likes Received:
    472
    Gender:
    Male
    Occupation:
    -= CEO =-
    Location:
    Heaven
    Home Page:
    well ... best seo plugin for wordpress is the platinum one , why do you need to switch ?
     
  3. ruler0fall

    ruler0fall Power Member

    Joined:
    May 17, 2009
    Messages:
    565
    Likes Received:
    263
    SEO Quake is an addon for firefox I think.
     
  4. hunar

    hunar Regular Member

    Joined:
    Jan 1, 2009
    Messages:
    479
    Likes Received:
    178
    Location:
    Minnesota
    Yeah Seo Quake is a plug-in for firefox.
     
  5. keinehabe

    keinehabe Supreme Member

    Joined:
    Nov 4, 2008
    Messages:
    1,207
    Likes Received:
    472
    Gender:
    Male
    Occupation:
    -= CEO =-
    Location:
    Heaven
    Home Page:
    have no idea :) ... since I have the perfect plugin for the needs , I don't need other ones :) and more I hate '' addons'' on my browsers only bookmarks feature I use when I need