1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Having some trouble with my site!!

Discussion in 'White Hat SEO' started by ukmoneymaker, Sep 20, 2012.

  1. ukmoneymaker

    ukmoneymaker Newbie

    Joined:
    Aug 27, 2012
    Messages:
    12
    Likes Received:
    1
    Hey guys. So heres the deal - About a month ago I resubmitted my site to google to be indexed ( it was indexed before but the site went down for a few months so it went off google)

    Now when I type the site into google, only the homepage appears when I typed in ".exactdomain"

    Any idea how to get the other pages reindexed as well?

    Thanks a lot,

    Al
     
  2. ksy213

    ksy213 Power Member

    Joined:
    Apr 24, 2011
    Messages:
    583
    Likes Received:
    152
    Check your webmaster tool to see any problem with those pages. Or Fetch as Google to check the crawlability of your site
     
  3. Endire

    Endire Elite Member Premium Member

    Joined:
    Mar 27, 2012
    Messages:
    1,756
    Likes Received:
    1,061
    Gender:
    Male
    Ukmoneymaker,

    There could be a variety of reasons your other URL's are not being indexed. Does your website utilize robots.txt and if so, is it properly configured? This file if not written correctly can cause pages not to be indexed. How is your link structure on your site? Is it easy for bots to crawl? Having links made out of JavaScript instead of anchor tags can cause problems for search engines crawling your site. Have you submitted a sitemap to webmaster tools? This helps Google (and other search engines) greatly with indexing all of your pages.

    There are some additional ideas in this thread,

    http://www.concrete5.org/community/forums/chat/site-wont-get-indexed-by-google/

    Hope that helps,

    Shawn