1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Have problems using vpn on a windows vps...

Discussion in 'BlackHat Lounge' started by SebastianJu, Jan 9, 2011.

  1. SebastianJu

    SebastianJu Power Member

    Joined:
    Mar 27, 2008
    Messages:
    679
    Likes Received:
    130
    Hello,

    did anyone succeed in establishing a vpn-connection on a windows vps? I rent a windows vps (virtuozzo seems to be the software) and wanted to run it as a client with a rent vpn. So i did not want to set up the vps as a vpn... the vps should be the client and on the vps there should run windows software.

    Now the problem is that it doesnt work. I tried 2 offers for vpns... both delivered a preconfigured openvpn-package. But when I start open vpn it tells me that "All TAP-Win32 adapters on this system are currently in use.".
    I used the batchfile that comes with openvpn and it created another tap-win32-adapter in hardware manager. But even after restarting server these adapters cant be initialised. They all have a yellow "!".

    The support of my vps told me that it wont work with openvpn. The reason probably is that its not a rootserver and so it cant access the hardware the same way like a rootserver could do. So the support told me it could be done by using the windows vpn client. I tried this too but even on my root-pc at home it didnt work. I presume the options that openvpn is setting in its config-file .ovpn needs to be implemented too. But I dont know how.

    I even was at the point where I tried to use a proxy for each software... less secure but when vpn isnt working... but the proxy works with the browser but not with my chat-software it seems. Need to clear this with my provider.

    But a working vpn would be much better, easier and more secure at the end...

    Does someone know how to do what I want? Do I need another vps or vpn?

    Thanks!
     
  2. asep_dadang

    asep_dadang Registered Member

    Joined:
    Aug 8, 2010
    Messages:
    66
    Likes Received:
    85
    Occupation:
    IM
    Location:
    Mother Earth
    so far i'm using openvpn in my windows vps (as client) and it works perfectly.

    you said that "All TAP-Win32 adapters on this system are currently in use", so openvpn program could be error during installation, have you tried to reinstall it? or just kill the openvpn process and then run again.
     
  3. asep_dadang

    asep_dadang Registered Member

    Joined:
    Aug 8, 2010
    Messages:
    66
    Likes Received:
    85
    Occupation:
    IM
    Location:
    Mother Earth
    so far i'm using openvpn in my windows vps (as client) and it works perfectly.

    you said that "All TAP-Win32 adapters on this system are currently in use", so openvpn program could be error during installation, have you tried to reinstall it? or just kill the openvpn process and then run again.