1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

GSA Error (download failed - SockError: Connection timed out)

Discussion in 'Black Hat SEO' started by lover, Jul 16, 2014.

  1. lover

    lover Jr. VIP Jr. VIP Premium Member

    Joined:
    Sep 25, 2007
    Messages:
    2,152
    Likes Received:
    812
    Location:
    BHW
    Hi Guys, getting lot of errors like this while running GSA campaigns...

    'download failed - SockError: Connection timed out'

    I am using proxies from Buyproxies.com. Checked proxies with other tools, they work fine.

    Anyone else facing this issue?
     
  2. yenerich

    yenerich Jr. VIP Jr. VIP Premium Member

    Joined:
    May 26, 2013
    Messages:
    1,007
    Likes Received:
    171
    Home Page:
    You are using just that proxies?

    You can check proxies with GSA to see if for GSA the proxies are fine or not.
     
    • Thanks Thanks x 1
  3. lover

    lover Jr. VIP Jr. VIP Premium Member

    Joined:
    Sep 25, 2007
    Messages:
    2,152
    Likes Received:
    812
    Location:
    BHW
    Yes, 50 dedicated proxies from buyproxies.

    When i check with GSA, all works fine but when running a campaigns, i get those errors. Proxies working fine with other softwares.
     
  4. mootonandy

    mootonandy Supreme Member

    Joined:
    Jun 21, 2010
    Messages:
    1,257
    Likes Received:
    236
    Yes I think i'm getting that too, GSA is the most complicated software I've ever used TBH.
     
    • Thanks Thanks x 1
  5. innozemec

    innozemec Jr. VIP Jr. VIP

    Joined:
    Aug 19, 2011
    Messages:
    5,290
    Likes Received:
    1,799
    Location:
    www.Indexification.com
    Home Page:
  6. lover

    lover Jr. VIP Jr. VIP Premium Member

    Joined:
    Sep 25, 2007
    Messages:
    2,152
    Likes Received:
    812
    Location:
    BHW
    Not all, but around 40%-50% of sites, these sites open in browser when i check manually so they are not down.
     
  7. innozemec

    innozemec Jr. VIP Jr. VIP

    Joined:
    Aug 19, 2011
    Messages:
    5,290
    Likes Received:
    1,799
    Location:
    www.Indexification.com
    Home Page:
    then probably the issue is with your proxies.. try removing the proxies and run SER for a while without proxies and see if you will notice the same error..
     
  8. lover

    lover Jr. VIP Jr. VIP Premium Member

    Joined:
    Sep 25, 2007
    Messages:
    2,152
    Likes Received:
    812
    Location:
    BHW
    Not sure because proxies working fine with other tools like WAC, FCS Networker etc. Cannot risk running GSA without proxies on my dedi.
     
  9. innozemec

    innozemec Jr. VIP Jr. VIP

    Joined:
    Aug 19, 2011
    Messages:
    5,290
    Likes Received:
    1,799
    Location:
    www.Indexification.com
    Home Page:
    yep, but you could be exceeding some simultaneous connections limit to your proxies or something alike...

    well, in that case simply continue using as is and ignore the errors...
     
  10. DX-GENERATION

    DX-GENERATION Jr. VIP Jr. VIP Premium Member

    Joined:
    Apr 14, 2010
    Messages:
    1,151
    Likes Received:
    254
    It is not related to your proxies!!! It is related to your system just wash out the cookies and reset your internet explorer. internet explorer you will find somewhere use my proxies !! i hope it will work for you !!!
     
    • Thanks Thanks x 1
  11. Peter Ngo

    Peter Ngo Jr. VIP Jr. VIP

    Joined:
    Apr 23, 2013
    Messages:
    1,837
    Likes Received:
    1,465
    Occupation:
    I browse BHW for a living
    Location:
    The Internet
    Can be a lot of site in your site list are dead.

    left click log --> untick enabled scrolling --> left click error --> Open URL.

    See if that can be opened, most likely if you proxies work, then those URLs are dead.
     
    • Thanks Thanks x 1
  12. berkay1907

    berkay1907 Jr. VIP Jr. VIP Premium Member

    Joined:
    Mar 25, 2012
    Messages:
    1,124
    Likes Received:
    595
    It happens on my comp. too. You have to restart your comp. It is not about proxies. It gives error bec of simultanious connections is too much. Restart your comp and decrease the connection number to half. It wasn't like this before but latest updates of GSA have this problem. It should be fixed asap. I see lots of people are getting this error.
     
    • Thanks Thanks x 1
  13. Cratos

    Cratos Jr. VIP Jr. VIP Premium Member

    Joined:
    Aug 16, 2012
    Messages:
    1,756
    Likes Received:
    1,095
    Gender:
    Male
    Occupation:
    SEO
    Location:
    Where The Elite SEOs Dwell
    happens over here with me also. It is not the proxies. I think its GSA SER. We need Santos to chime in on this..

    If you look at the serps. Seems that allot of us users have been running into this same problem lately. Still don't find a solution for it though.
     
    • Thanks Thanks x 1
  14. umerjutt00

    umerjutt00 Jr. VIP Jr. VIP Premium Member

    Joined:
    Oct 28, 2011
    Messages:
    3,649
    Likes Received:
    1,908
    Occupation:
    Ninja
    It can be:

    1. The target links are dead.
    2. Your timeout settings are not good. Try increasing the timeout.
    3. Also check out the option: continously try posting on site even if it failed before.
    4. Your proxies are not good.
     
    • Thanks Thanks x 2
  15. lover

    lover Jr. VIP Jr. VIP Premium Member

    Joined:
    Sep 25, 2007
    Messages:
    2,152
    Likes Received:
    812
    Location:
    BHW
    Thanks guys,tried most of the stuff posted here, including running just 50 threads with 50 proxies with 180 timeout setting, but still getting those errors.

    I am able to open sites manually in browser for which GSA is showing download error. My target list is fresh and verified.

    Proxies working fine with all the other tools, so looks like issue with GSA SER.
     
    Last edited: Jul 17, 2014
  16. s4nt0s

    s4nt0s Jr. VIP Jr. VIP Premium Member

    Joined:
    Jul 10, 2009
    Messages:
    3,663
    Likes Received:
    1,940
    Location:
    Texas

    I actually spoke with Sven about this yesterday and he said he has debugged this extensively this week and hasn't found any issue and said most of the time its the proxies going wild. All he did was add more detailed error messages so its throwing people off. People were use to just seeing "download failed" but now the error messages are more detailed. Also network issues cause these problems.


    Keep in mind this message is going to happen no matter what at different times and that's normal. Of course if you aren't getting many links, that's the problem. Power users like Ron said he see's this message all over his log but still gets 400 LPM.


    Here's what I use and my proxy settings and I'm getting great LPM.


    Proxies: 50 shares proxies from proxy-n-vpn
    Dedicated server: SSD 300 package from SolidSEOVPS


    Proxy settings:


    [​IMG]


    Here, after I test proxies, I'll sort them by clicking the speed column and uncheck the proxies that are slow. I usually uncheck proxies over 1.0 ms because even if proxies test as good, if they're slow they can still cause problems.


    [​IMG]


    Nothing is checked here, but you can always test those last two options "proxies should resolve domain to IP" and "Try using proxy-keep-alive". You can toggle those on or off and see if that helps.


    [​IMG]


    For captchas I'm using CB as my primary and Expert Decoders as a fallback.
     
    • Thanks Thanks x 3
  17. Cratos

    Cratos Jr. VIP Jr. VIP Premium Member

    Joined:
    Aug 16, 2012
    Messages:
    1,756
    Likes Received:
    1,095
    Gender:
    Male
    Occupation:
    SEO
    Location:
    Where The Elite SEOs Dwell
    freaking awesome Santos I knew you would come through with a quality post and answer. Read that post about Ron also. Gonna edit some of those settings and see whats up. Thanks for posting the thread also lover.
     
    • Thanks Thanks x 2