1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Got hacked??

Discussion in 'Black Hat SEO' started by bulldogzg, Nov 22, 2011.

  1. bulldogzg

    bulldogzg Senior Member

    Joined:
    Sep 14, 2010
    Messages:
    830
    Likes Received:
    282
    Home Page:
    Well here is the thing. And any help would be greatly appreciated since I'm lost here.

    A couple of days ago I noticed one of my inner pages has got a wrong title indexed. Since it's impossible for that kind of "mistake" I was sure sth is wrong, but I did first try changing the title and waited to get indexed.

    After it got indexed same thing happened again.
    Wrong title

    Also about the same time this page (and only this page) loading time was ridiculous - anywhere between 15 and 30 seconds. Contacted my web hosting service but it was all fine from their end and my home page was loading for 2.2 so it was not that.
    I must also note that I'm on middle of page one for a few very competitive KW's so my bounce rate was 90% or higher.

    I played with W3 cache plugin and got the loading time of this page to 5 seconds (still very slow).

    Toady I went into my webmaster tools and tried the "fetch as googlebot" command and after 2 "failed" and 2 "time-outs" I finally got my results.

    Turns out I have a permanent 301 setup :questionm
    I only did change my permalinks but never did a 301 - is this the same, and if so why aren't my other pages affected?

    Checked all of my other pages and they work fine so now I'm stuck and don't know what to do... I did check my .htaccess file but still didn't find anything suspicious.

    Any tips? Anyone had a similar problem?

    Thanks for reading I know it was a lot of text.
     
  2. Markthedude

    Markthedude Power Member

    Joined:
    Feb 26, 2010
    Messages:
    572
    Likes Received:
    266
    Occupation:
    Entrepreneur
    Location:
    United States
    I'm not an expert but if you are running wordpress maybe this can help.

    Install Firewall2, it will tell you if scripts are trying to run, either from your site or at your site.

    Install TAC (Theme Authenticity Checker) , it will let you know if they're are hidden links or code within your site.

    Contact your hosting too, if you have hostgator DO NOT say hacked, they will refuse to help, one of the chat people told me that when I told him I was hacked. Just ask them to look at that page since you tried to setup a 301 and see what they say, if they say yeah it's working, ask them how you can remove it since you forgot how you set it up since it was so long ago or something.

    Also, scan your site through these two sites:

    Code:
    http://www.unmaskparasites.com
    Code:
    http://sitecheck.sucuri.net/scanner/
    Hope this helps a little!
     
    • Thanks Thanks x 2
    Last edited: Nov 22, 2011
  3. bulldogzg

    bulldogzg Senior Member

    Joined:
    Sep 14, 2010
    Messages:
    830
    Likes Received:
    282
    Home Page:
    Thanks + rep Mark!
    I'm gonna try it out and report back. Really appreciate the response
     
  4. Markthedude

    Markthedude Power Member

    Joined:
    Feb 26, 2010
    Messages:
    572
    Likes Received:
    266
    Occupation:
    Entrepreneur
    Location:
    United States
    Glad I could help and thanks for the Rep ;)