1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[?] Google Webmaster Tool - Pending Problem

Discussion in 'White Hat SEO' started by powpew, Apr 1, 2012.

  1. powpew

    powpew Regular Member

    Joined:
    Oct 30, 2011
    Messages:
    209
    Likes Received:
    44
    Howdee Blackhatters?!

    I've got an issue with the G Webmaster Tool and if anyone can shed some light over it will be greatly appreciated!

    I've got a 1-month old wordpress website with 10 content-rich posts (ranging 200-1000 words per post). I have got only the first 2 posts out of 3 indexed in the first week. Since then, I've been adding constantly adding posts and hoping G would index them naturally and that never happened. So just 2 posts out of 10 indexed. Yesterday, I got really pissed and decided to submit a sitemap to Webmaster Tool account (I always use 1 account per 1 website) and from my experience with the other sites I own there should have been some movement from the crawlers. Guess what? After 24 hours, under the "Processed" column it shows pending.

    Has anyone else got this kind of issue? And if yes, how did/do you deal with it and get your posts indexed?

    Cheers and Thanks for your time!
     
  2. arousso

    arousso Registered Member

    Joined:
    Jan 11, 2012
    Messages:
    55
    Likes Received:
    10
    I had that problem a few weeks ago with a news sitemap. I kept resubmitting the sitemap. Then I googled using site:url and it was indexed but the posts were still showing "pending".

    Also one time I had trouble with one post about the Miami Heat, after about 30 minutes of messing with it I change the title and permalink and it indexed right away.
     
  3. powpew

    powpew Regular Member

    Joined:
    Oct 30, 2011
    Messages:
    209
    Likes Received:
    44
    any other ideas or experiences? it's really bugging the crap out of me :/
     
  4. PseudoVeracity

    PseudoVeracity Newbie

    Joined:
    Mar 28, 2012
    Messages:
    7
    Likes Received:
    4
    Location:
    The Earth
    How many backlinks do you have? In the past I've found Google very slow to index my new websites - until I got a few well-indexed backlinks. Then - Bam! They started showing the site in search results pretty much straight away.

    If you've got some other websites with a fair bit of search traffic, I'd recommend placing a site-wide link to your new site in the footer. Give it a day or two and see what turns up in a site:url search then.
     
  5. zazaro

    zazaro Newbie

    Joined:
    Nov 10, 2008
    Messages:
    20
    Likes Received:
    18
    Occupation:
    WebMaster
    Location:
    Romania
    Home Page:
    In general after you submit the xml sitemap in 3-4 days all of your pages shoud be indexed.Try to rebuilt the sitemap from wordpress,I presume you have a plugin for this.
    google search with : site:yoursite.domain
     
  6. powpew

    powpew Regular Member

    Joined:
    Oct 30, 2011
    Messages:
    209
    Likes Received:
    44
    Thank you for the replies mates.

    Apparently it was a problem with my hosting account as they put some temporary 302 redirect filters in order to fix some issues and keep bots away in the mean time. Damn, I got so mad at Google for nothing :)

    Submitted the sitemap successfully, now patiently waiting for the pages to get indexed.

    Cheers