1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Google Webmaster Tool Expert Help

Discussion in 'White Hat SEO' started by K.H.R, Dec 14, 2014.

  1. K.H.R

    K.H.R Jr. VIP Jr. VIP Premium Member

    Joined:
    Dec 9, 2013
    Messages:
    2,926
    Likes Received:
    950
    Gender:
    Male
    Occupation:
    Study + Outsourcing
    Location:
    BHW
    Hello BHW,

    Yesterday I submitted my Sitemap in Webmaster Tool. Sitemap Generated by Yoast's WordPress SEO plugin. Sitemap index Pending But site:mysite.com showing 51 page is indexed. Google just indexed the Category & Menu Bcoz no article posted yet. Webmaster Tool Also Showing an Index Error & robots.txt Tester Error :

    [​IMG]


    [​IMG]

    How can I fix this Error ? Please Help Me...

    Thanks in Advice.
     
  2. SeoReborn

    SeoReborn Newbie

    Joined:
    Jan 16, 2014
    Messages:
    17
    Likes Received:
    3
    Have you checked the actual 404 pages? Are they live or really 404?
     
  3. K.H.R

    K.H.R Jr. VIP Jr. VIP Premium Member

    Joined:
    Dec 9, 2013
    Messages:
    2,926
    Likes Received:
    950
    Gender:
    Male
    Occupation:
    Study + Outsourcing
    Location:
    BHW
    404 Page is Live. I posted a Test Post & also deleted that, when I check this Its showing 404 page, So 404 page is live & Working Good.

    You can check this here :
    Code:
    http://www.techtracknews.com/the-ipad-mini-has-arrived-here-is-our-review
     
  4. dsan996

    dsan996 Regular Member

    Joined:
    Apr 18, 2014
    Messages:
    228
    Likes Received:
    101
    Location:
    Depends on the day
    Hi there, I'm no expert on WMT but I'm telling you what I think is going on. I see two different issues not related to each other:

    - The robots.txt warning is appearing because Google does not support the crawl-delay directive so they are waring you that they will ignore it. Not a real problem though. Just if you want to limit the googlebot crawl rate you can do so in WMT settings -> Site settings -> Crawl rate.

    - The other issue is the sitemap index warning. It looks like your taxonomies are not being included in the sitemap, thats why the category and tag sitemap are returning a 404. I once managed to solve this by forcing Yoast to include each single category in the sitemap, though I can not assure that this will work for you: on each specific category/tag editing page you'll find the Yoast settings. At the very bottom there is the option "Include in sitemap?". Set that to "Always include". You must repeat the process for every single category and tag.
     
  5. K.H.R

    K.H.R Jr. VIP Jr. VIP Premium Member

    Joined:
    Dec 9, 2013
    Messages:
    2,926
    Likes Received:
    950
    Gender:
    Male
    Occupation:
    Study + Outsourcing
    Location:
    BHW
    But in the Crawl Section in Webmaster Tool There is no Error:

    [​IMG]

    Crawl Status:

    [​IMG]

    But in the Index Status Showing 0 Indexed. in site:mysite.com showing 53.
    Do You think is this OK ?
     
  6. SeoReborn

    SeoReborn Newbie

    Joined:
    Jan 16, 2014
    Messages:
    17
    Likes Received:
    3
    Try loading your page as googlebot. You can do that via WHM or use a browser plugin. Firefox and chrome has it.
     
  7. jahbuzor

    jahbuzor Registered Member

    Joined:
    Feb 16, 2011
    Messages:
    70
    Likes Received:
    12
    Occupation:
    Internet Marketer
    Location:
    Nigeria
    Home Page:
    Use the YOAST SEO to strip the category base from the category url (Yoast >> Permalinks). I think it should be the problem.
     
  8. seosimplykills

    seosimplykills Newbie

    Joined:
    Sep 6, 2014
    Messages:
    14
    Likes Received:
    0
    If your pages are accessible then simply ignore the warning.
     
  9. SeoReborn

    SeoReborn Newbie

    Joined:
    Jan 16, 2014
    Messages:
    17
    Likes Received:
    3
    ^^ this. If you are getting indexed pages showing up using site: command in google then it could be a glitch in webmaster tools. It may just sort itself out over several days.
     
  10. dorasdr

    dorasdr Regular Member

    Joined:
    Feb 2, 2014
    Messages:
    456
    Likes Received:
    114
    Two days back i completed my website

    What are the basic steps need to do like "submitting site to Google and add in webmaster tools" etc for ranking my website

    I want to apply adsense with my website. So please suggest some white hat methods
     
  11. Ganes

    Ganes Newbie

    Joined:
    Oct 27, 2014
    Messages:
    17
    Likes Received:
    2
    Occupation:
    Senior SEO Key Account Manager
    Location:
    Cologne
    That seems like a different topic. You might want to read "The Complete Guide to Starting a Website" and "Basic SEO practices for newbies" first. You can find them when you head back to White Hat SEO at the very top of the threads list. Good luck :)
     
  12. dorasdr

    dorasdr Regular Member

    Joined:
    Feb 2, 2014
    Messages:
    456
    Likes Received:
    114
    thanks for your suggestion

    For submitting site to google is it better to create new google account or shall i use my existing google account.

    With my existing google account i applied to adsense with my blogger website and got rejected

    Please help and sorry for my bad english