1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Google Screwing with my Head and Youtube video

Discussion in 'YouTube' started by oldweb, Jan 23, 2016.

  1. oldweb

    oldweb Regular Member

    Joined:
    Dec 22, 2012
    Messages:
    448
    Likes Received:
    45
    Why has Google dropped my video from it's search?

    I have not really seen this much in the past but after uploading a video and adding lots of social linking to it as I would normally do, adding some comments, likes and views (all manually). So it gets on Page 1 of Google. But a few days later it's gone, nothing, not even if I enter the video url in Google will it even show. it is still on Youtube and there are no warnings or issues with YT.

    I went back changing the video title, adding more tags, changing the description etc and a few other things but it made no difference. I also added more social links but that also made no difference.

    This is really discouraging, what is going on here?
     
    Last edited: Jan 23, 2016
  2. sherryhairyberry

    sherryhairyberry Junior Member

    Joined:
    Apr 16, 2010
    Messages:
    109
    Likes Received:
    19
    Were you able to find out what the problem was?
     
  3. b6ainy

    b6ainy Regular Member

    Joined:
    Apr 12, 2015
    Messages:
    305
    Likes Received:
    70
    Gender:
    Male
    I think google find your Video not related
     
  4. oldweb

    oldweb Regular Member

    Joined:
    Dec 22, 2012
    Messages:
    448
    Likes Received:
    45
    not really but I did some fresh round of social linking and it was back again in google and since then has enjoyed some reasonable rankings.
     
  5. darkreaction

    darkreaction Registered Member

    Joined:
    Jun 11, 2014
    Messages:
    86
    Likes Received:
    4
    Occupation:
    IM / AM
    Location:
    Canada
    I would be more concerned with analytics and metrics myself rather than a search result in some browser. If all of those are OK and acting as they should, just be patient.