1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Google isn't changing my title tag and description info

Discussion in 'White Hat SEO' started by ibmethatswhoib, Aug 19, 2016.

  1. ibmethatswhoib

    ibmethatswhoib Jr. VIP Jr. VIP Premium Member

    Joined:
    Feb 17, 2011
    Messages:
    1,560
    Likes Received:
    1,164
    Occupation:
    Staying Informed
    Location:
    Bay Area, Ca
    Home Page:
    I have never had this happen before, I changed my title tag, description and the only thing I left the same is the URL but it still shows the old title tag. I changed it like a month ago, and still the same. I checked using a fresh cleared browser and it crawls my page all the time. I also used the fetch as Google in webmaster tools and it shows the correct info but hasn't changed in the serps. Now idea what's happening?
     
  2. validseo

    validseo Jr. VIP Jr. VIP Premium Member

    Joined:
    Jul 17, 2013
    Messages:
    910
    Likes Received:
    527
    Occupation:
    Professional SEO
    Location:
    Seattle, Wa
    1. It can take a week or two after google updates the google cache to reflect the change. Check your google cache entry for the change and the cache date.
    2. If google doesn't like your title they will craft their own for you. Look at other titles that rank and be like those.
    3. Googles summary is the first relevant blurb... which sometimes is your meta description, but not always.
    4. If you use schema markup then google crafts its own summary which may or may not include meta description text.
     
    • Thanks Thanks x 1
  3. Ronald2000

    Ronald2000 Registered Member

    Joined:
    Nov 5, 2012
    Messages:
    52
    Likes Received:
    2
    it also happen to me dude but sometimes it takes a little longe so you just need to wait.
     
  4. mbreezy

    mbreezy Jr. VIP Jr. VIP

    Joined:
    Jun 27, 2012
    Messages:
    488
    Likes Received:
    162
    is it within the pixel with limit? maybe you've added too many keywords and it seems like spam.
     
  5. engra

    engra Registered Member

    Joined:
    Jul 14, 2016
    Messages:
    54
    Likes Received:
    13
    Gender:
    Male
    I had similar issue with one domain, it took a long time, more than one month for sure. Cheers