1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Google Indexing doesn't work.

Discussion in 'White Hat SEO' started by Walid333, Jun 19, 2017.

  1. Walid333

    Walid333 Junior Member

    Joined:
    Jan 14, 2017
    Messages:
    108
    Likes Received:
    41
    Gender:
    Male
    Hi, I have a site with a few keywords I'm trying to rank up on,

    I had a different domain, I switched it to a .com. same domain name just at the end .com
    It's the same site but now the indexing doesn't work, I've requested it multiple times it just doesn't work.

    I don't see my site on any of those keywords, anyone knows how do i get this to work?
     
  2. ancientaliens

    ancientaliens Regular Member

    Joined:
    Jul 13, 2015
    Messages:
    371
    Likes Received:
    175
    Occupation:
    Extraterrestrial
    Location:
    Scorpius Constellation
    Using webmaster tools?
     
  3. Walid333

    Walid333 Junior Member

    Joined:
    Jan 14, 2017
    Messages:
    108
    Likes Received:
    41
    Gender:
    Male
    Yes. was working completely fine for the other domain until i switched to a .com domain
     
  4. bartosimpsonio

    bartosimpsonio Jr. VIP Jr. VIP Premium Member

    Joined:
    Mar 21, 2013
    Messages:
    12,765
    Likes Received:
    11,423
    Occupation:
    COINZ
    Location:
    BUYAH
    Home Page:
    If it's a brand new domain it'll take a while for GWT to start being fast for it.

    First the domain has to get into their main index, only then the page indexing becomes faster. This is taking longer and longer as others have reported.

    Make sure to 301 the entire site over, and do the change on GWT itself, (website address change). If you've completed all that, then there's nothing else you can do to speed things up.
     
  5. Nargil

    Nargil Jr. VIP Jr. VIP

    Joined:
    May 10, 2012
    Messages:
    5,022
    Likes Received:
    3,195
    Location:
    Europe
    Home Page:
    How is it a same site? If you are trying to index a copy of a site which is still in index, then it will never get indexed, because it's a duplicate.

    If that's not true, then if it's an EMD, then there's a good chance it's penalized.
     
  6. Walid333

    Walid333 Junior Member

    Joined:
    Jan 14, 2017
    Messages:
    108
    Likes Received:
    41
    Gender:
    Male
    i think this is the issue, im trying to index a copy of a site which is still in index. but the thing is I don't have access to the indexed domain, or hosting. I deleted everything from it, but it's still in index. Now that domain just leads to some random site that isn't even mine, how do I get it removed? I already tried re-indexing that site in hope that it will disappear but nothing happens.
     
  7. JustCash

    JustCash Marketplace seller Marketplace seller Premium Member

    Joined:
    Jun 8, 2017
    Messages:
    113
    Likes Received:
    11
    Gender:
    Male
    Home Page:
    • Thanks Thanks x 1
  8. Walid333

    Walid333 Junior Member

    Joined:
    Jan 14, 2017
    Messages:
    108
    Likes Received:
    41
    Gender:
    Male
    Seems like you were right! I waited about 2 days and when I checked today the site is indexed.
    I thought I fucked up badly or something, thanks everyone that helped :D
     
    • Thanks Thanks x 1
  9. Parker2010

    Parker2010 Jr. VIP Jr. VIP

    Joined:
    Apr 27, 2017
    Messages:
    819
    Likes Received:
    192
    Gender:
    Male
    Occupation:
    SEO Consultant
    Location:
    BHW
    Home Page:
    No worries, the old site will get de-indexed soon with the time.