1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Google blocking my zenno search bot?

Discussion in 'Black Hat SEO' started by Ranko Jones, Mar 24, 2012.

  1. Ranko Jones

    Ranko Jones BANNED BANNED

    Joined:
    Mar 3, 2011
    Messages:
    1,677
    Likes Received:
    146
    This is typical; I spent the whole last two + days working on refining my zenno kw research bot and today I login eager to take it for a spin and fucking google seems to be blocking it somehow.

    The bot begins by putting a keyword into google search and hitting search. Now I dont get how it's doing it but you know when you hit search and it's greyed out well it just stays jammed there.

    After a bit I will go try and search normally without a bot and google tells me I'm banned for 'unusual activity' or whatever the fuck and have to enter the captcha.

    I understand if the bot was running real fast but it does this on the first hit of the search button!

    It was working fine before while I was making the script up till now; just today it's throwing this crap at me. I dont get how they could ascertain it was a bot just from that first click of the search. Any ideas?

    I think the reason for the ban is cos for some reason zenno is loading tons of different explorer browsers while it stays jammed - thats what its doing when I tried to rerecord the search button. Guess this is a pretty zenno specific problem so better head over to the zenno forums for this one.
     
    Last edited: Mar 24, 2012
  2. Espeed

    Espeed Newbie

    Joined:
    Dec 7, 2010
    Messages:
    14
    Likes Received:
    1
    Damn that sucks, it sounds like a good tool. Is it using the same IP address over and over again? That might be how they are blocking it.
     
  3. LBrown

    LBrown Senior Member

    Joined:
    Mar 22, 2011
    Messages:
    1,109
    Likes Received:
    1,827
    Occupation:
    Internet Marketer - Full Timer
    Location:
    The Land of the Brave
    Proxies would be my guess. You mentioned nothing about what you're using for proxies. I would guess that whatever you are using aren't secure.
     
  4. Scripteen

    Scripteen Elite Member

    Joined:
    Sep 19, 2009
    Messages:
    1,811
    Likes Received:
    1,918
    Home Page:
    Are you doing normal search or using special operators like allintitle: and site: etc? Google has lower limits on these operators than the usual search.

    Add support for proxies in your bot and buy a bunch or private proxies and also use multiple user agents and rotate them randomly with each search.
     
  5. Ranko Jones

    Ranko Jones BANNED BANNED

    Joined:
    Mar 3, 2011
    Messages:
    1,677
    Likes Received:
    146
    Its working again now, no dont require proxies usually since it takes a few seconds between searches but I was getting blocked that 1st time for some reason.
    ----

    In case i havent figured it out before someone replies can they tell me how I use the dupe remove string processing macro? Just trying to get it now.

    Here is what I have so far: {-String.RemoveDuplicates-|-{-File.GetString-|-{-Project.Directory-}dupetest.txt-|-0-end-|-false-}-|--}

    but it doesnt do anything, it shows the file data in the log so it's being accessed but doesnt remove anything.

    the data is going to be one line per data item but Im not sure what the correct separator would be?

    ie
    keyword1
    keyword2
    keyword3

    The default separator didnt do anything either so not sure what to try next. Thoughts?

    Guess Ill use trusty SB to remove them in the meantime.
     
    Last edited: Mar 24, 2012