1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Google Analytics Issue

Discussion in 'White Hat SEO' started by Dodge, Aug 4, 2011.

  1. Dodge

    Dodge Regular Member

    Joined:
    Jul 29, 2009
    Messages:
    389
    Likes Received:
    53
    Hi there,

    I've just tried installing Google Analytics using two different plugins on my Word Press blog, but it still says "tracking unknown" on Analytics. I understand that it takes some time for the report to update, but am I right in saying that if my correct Analytics code has been put into WP by the plugin then it should immediately recognise that that has happened?

    IF that is the case then there is clearly another issue and I need to figure out what!

    Cheers!

    Edit: I just found out that it's not automatic and that I need to wait!
     
    Last edited: Aug 4, 2011
  2. cyberzilla

    cyberzilla Elite Member Premium Member

    Joined:
    Nov 15, 2009
    Messages:
    2,204
    Likes Received:
    3,363
    Location:
    zeta reticuli
    Go to Website profiles-->Edit--> Click on "Check status"

    I usually edit the header file directly and add it. GA automatically recognize it and pull the data after some times.
     
  3. milian

    milian Power Member

    Joined:
    Jan 9, 2010
    Messages:
    515
    Likes Received:
    69
    Occupation:
    SEO stuff
    Location:
    Around
    if you have access to your server via ftp, just add the code that way. Better IMO if especially if you are having issues with plugins.

    Also dont add it twice with two different plugins

    I think it took a couple of days for mine to get picked up
     
  4. Dodge

    Dodge Regular Member

    Joined:
    Jul 29, 2009
    Messages:
    389
    Likes Received:
    53
    Thanks guys :) The reason I didn't want to add it manually was that it said on GA that I'd need to do it manually for each page?
     
  5. cyberzilla

    cyberzilla Elite Member Premium Member

    Joined:
    Nov 15, 2009
    Messages:
    2,204
    Likes Received:
    3,363
    Location:
    zeta reticuli
    No! just one time in the header file. Just follow the instruction given in GA.
     
    • Thanks Thanks x 1
  6. Dodge

    Dodge Regular Member

    Joined:
    Jul 29, 2009
    Messages:
    389
    Likes Received:
    53
    Okay great thanks :) I disabled the plugins and just went opened up the header.php file in my theme on WP and added it in!

    Hopefully that sorts it, thanks guys!