Extracting Themes to Wordpress Problem

Discussion in 'Web Design' started by especial, Jul 25, 2010.

  1. especial

    especial Registered Member

    Joined:
    Jul 11, 2009
    Messages:
    82
    Likes Received:
    9
    Location:
    Calgary
    Good day
    I having this problem and its getting annoying
    I have downloaded a lot of themes and I would say most or majority of the themes always show me an error of this

    The following themes are installed but incomplete. Themes must have a stylesheet and a template.

    Stylesheet is missing.

    Please Advise
    Thanks
     
  2. shekar

    shekar Registered Member

    Joined:
    Apr 6, 2009
    Messages:
    62
    Likes Received:
    3
    download full themes from www dot boygj dot com, thats where i get all my themes
     
    • Thanks Thanks x 1
  3. origin

    origin Regular Member

    Joined:
    Nov 11, 2008
    Messages:
    333
    Likes Received:
    91
    Some theme archives stored double directories. When you install one theme, it's actually only extracting it on a directory and then WP tells you a broken theme.

    If you see directory structure:
    Code:
    /wp-content/themes/yourthemename/yourthemename
    It should be:
    Code:
    /wp-content/themes/yourthemename
    Just move all content of the last yourthemename to the first yourthemename directory, delete the 2nd one after moving it.
     
    • Thanks Thanks x 1
  4. especial

    especial Registered Member

    Joined:
    Jul 11, 2009
    Messages:
    82
    Likes Received:
    9
    Location:
    Calgary
    arggh i'm still having the same shit.!!!
    It there anything to do with my cpanel or my wordpress i'm currently using wp 3.0 :suspicious:
     
  5. especial

    especial Registered Member

    Joined:
    Jul 11, 2009
    Messages:
    82
    Likes Received:
    9
    Location:
    Calgary
    Btw any good tutorials on building a good wp site? Ive seen many but all tutorials are locked
     
  6. islandman1010

    islandman1010 Elite Member

    Joined:
    May 10, 2008
    Messages:
    1,910
    Likes Received:
    358

    Are the ones you are trying to use all compatible with WP 3.0 ?