1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Embedded Youtube videos show only volume

Discussion in 'Web Design' started by Scorpion Ghost, Aug 11, 2015.

  1. Scorpion Ghost

    Scorpion Ghost Senior Member

    Joined:
    Mar 22, 2013
    Messages:
    1,026
    Likes Received:
    218
    Occupation:
    Internet!
    Location:
    On the Interwebz
    Home Page:
    I have a small issue on my site. Users are allowed to embed Youtube videos. With the new update Youtube had recently where the player was changed, for some reason while a video is playing the only thing one can see on bottom of the video is the volume bar. So the play/pause button, the watch on youtube button, the full screen button, those cannot be seen. Those buttons are actually there and can be clicked even, if you know where they are. But they're not visible, so that's a problem.

    This is the code used in my theme for Youtube videos:

    Code:
    echo '<iframe style="margin-right:10px;margin-bottom:10px" width="400" height="400" src="http://www.youtube.com/embed/'.$code_here.'"
    Does anyone have any idea how to fix this?

    Thanks
     
  2. Scorpion Ghost

    Scorpion Ghost Senior Member

    Joined:
    Mar 22, 2013
    Messages:
    1,026
    Likes Received:
    218
    Occupation:
    Internet!
    Location:
    On the Interwebz
    Home Page:
    Actually, I just checked it and it's doing it only on Firefox. On Chrome and Internet Explorer it works fine. Weird shit...

    It works fine on Internet Explorer but not on Firefox. What's wrong with the world today? I'm not leaving the house today. A fridge might fall on my head out of the sky. That's an impossibility for it to work on IE but not on the 100 times better Firefox. Wow...
     
  3. nisdee

    nisdee Regular Member

    Joined:
    Nov 16, 2014
    Messages:
    353
    Likes Received:
    122
    Location:
    Rainbow Land
    Try to put insert z-index 99 or something high like that, I think it won't help but worth a try..
     
  4. Scorpion Ghost

    Scorpion Ghost Senior Member

    Joined:
    Mar 22, 2013
    Messages:
    1,026
    Likes Received:
    218
    Occupation:
    Internet!
    Location:
    On the Interwebz
    Home Page:
    Thanks man. I tried it, but it didn't make any difference.
     
  5. Ramse

    Ramse Jr. VIP Jr. VIP Premium Member

    Joined:
    Jan 6, 2014
    Messages:
    816
    Likes Received:
    93
    Home Page:
    Have you checked are there any updates in the embedding code?
    Maybe You Tube changed the embedding code?
     
  6. Scorpion Ghost

    Scorpion Ghost Senior Member

    Joined:
    Mar 22, 2013
    Messages:
    1,026
    Likes Received:
    218
    Occupation:
    Internet!
    Location:
    On the Interwebz
    Home Page:
    I did look into that. Tried googling about it. I didn't really find anything helpful about that.

    Thing is, it works fine on Chrome and on Internet Explorer. It's just not working fine on Firefox. I even eventually ran into an embedded video on some other website, played it, and had the same issue. It must be a Firefox problem or something. I don't know, really.