1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Draft Scheduler skips days when scheduling

Discussion in 'Blogging' started by tok997, Jul 10, 2014.

  1. tok997

    tok997 Registered Member

    Joined:
    Jun 28, 2014
    Messages:
    55
    Likes Received:
    10
    Hi guys!

    I hope somebody will be able to help me. I'm using Draft Scheduler for my autoblogs. It works great except one thing ? when all drafts are being scheduled (for example for 50 days in advance) it skips dates which end with zero (so each 10th, 20th and 30th day of each month). I'm not good with code, so I'd really appreciate if anybody could look at it and identify/fix the problem. Sorry if I'm asking too much. Unfortunately author of the plugin is not active on support forum on wordpress website. Here's the link to the plugin ? wordpress (dot) org/plugins/drafts-scheduler/

    I've tried a lot of different plugins which can schedule drafts and this one is the best so far (even though it has this bug).

    Thank you in advance!
     
  2. tok997

    tok997 Registered Member

    Joined:
    Jun 28, 2014
    Messages:
    55
    Likes Received:
    10
    Forgive me, but I decided to paste a code of a plugin here. I just thought that people who may be able to help won't have time to go to WP website to download the plugin and look at code. If it's inappropriate I ask moderators to delete it then. Thanks.

    Update: Sorry, I put the code inside CODE tags but it wasn't displayed properly. So I'm not sure how to put it in here.
     
    Last edited: Jul 10, 2014
  3. Dennyy

    Dennyy Regular Member

    Joined:
    May 16, 2013
    Messages:
    341
    Likes Received:
    78
    Oh can you post it in pastebin? And thanks a lot for figuring this coding error out!
     
    • Thanks Thanks x 1
  4. tok997

    tok997 Registered Member

    Joined:
    Jun 28, 2014
    Messages:
    55
    Likes Received:
    10
    Thanks for the tip with pastebin Dennyy! Here's what goes after the slash in the pastebin's domain name: 4XT808PY (forum gives me hard time pasting in links).

    I'm not sure if code from js files in the plugin is necessary.

    Thanks!