backlinks in webmaster tools but not elsewhere?

majestry

Junior Member
Joined
Nov 14, 2008
Messages
161
Reaction score
25
I've gotten a good amount of links to my website. A few of them show up in my webmaster tools page in google but when I search for links to my page in things like yahoo or google it says that there are no links to my page. Any reason why this is? I've got a great keyword and a good targeted website and I'm trying to rank for it but my backlinks don't seem to be registering.
 
how did you search google?

Think it needs to be like this "link: domain.com
 
Very odd. They usually always show up in yahoo and if nothing or just one or two show in google that was the norm.
 
Very odd. They usually always show up in yahoo and if nothing or just one or two show in google that was the norm.
Another thing I noticed is that my website for my primary search term is no longer showing up in the serps. It wasn't very high (~200) but it's still indexed by google. Why would my ranking for the keyword just fall off like that?
 
Have you built any links to your site? Changed anything either on or off your site recently?
 
Have you built any links to your site? Changed anything either on or off your site recently?

I added links today but I hadn't for a while. It has been sort of on the back burner for a few weeks and I'm finally starting to put some effort back into it.
 
Back
Top
AdBlock Detected

We get it, advertisements are annoying!

Sure, ad-blocking software does a great job at blocking ads, but it also blocks useful features and essential functions on BlackHatWorld and other forums. These functions are unrelated to ads, such as internal links and images. For the best site experience please disable your AdBlocker.

I've Disabled AdBlock