1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Ask - Google not showing description

Discussion in 'White Hat SEO' started by blackhataffiliate, May 27, 2010.

  1. blackhataffiliate

    blackhataffiliate Senior Member

    Joined:
    Oct 19, 2008
    Messages:
    847
    Likes Received:
    1,365
    Location:
    USA
    Okay, all of a sudden G is not showing my description in the serps. All i have is my domain and title

    Keyword Rich Title
    www.mydomain.com/

    I did make some changes to other pages, but not the main index page so there should not be any change. I have poured over the code to find any (accidental) mistakes but can not find any. Any ideas as to why this happened and how to get the serps updated?
     
  2. ZMakarov

    ZMakarov Registered Member

    Joined:
    May 5, 2010
    Messages:
    81
    Likes Received:
    5
    Hello there !!

    For the description to appear in the SERP's,
    you need the description meta tag.
    I wonder if someone removed it by mistake?
    Check if it is there and tell us.
    :)
     
  3. darkfury

    darkfury Regular Member

    Joined:
    Oct 23, 2008
    Messages:
    265
    Likes Received:
    141
    Location:
    Scotland
    do a search on google for online meta tag analyzers and run your homepage url through them, see if they bring back the correct info

    try this one h**p://***.hypergurl.c*m/form.html
     
    • Thanks Thanks x 1
  4. speedy5044

    speedy5044 Regular Member

    Joined:
    Jul 29, 2008
    Messages:
    456
    Likes Received:
    993
    Occupation:
    IM
    Are you using wordpress? if so check your privacy setting and choose "I would like my blog to be visible to everyone, including search engines (like Google, Bing, Technorati) and archivers"
     
  5. blackhataffiliate

    blackhataffiliate Senior Member

    Joined:
    Oct 19, 2008
    Messages:
    847
    Likes Received:
    1,365
    Location:
    USA
    Thanks for all the suggestions. I have no idea what happened, but it was gone until this morning. I resubmitted my index page (no changes made) and it was back this morning. I guess it was just a G thing