1. This website uses cookies to improve service and provide a tailored user experience. By using this site, you agree to this use. See our Cookie Policy.
    Dismiss Notice

Any Wordpress user can solve this problem? Please

Discussion in 'Blogging' started by anil2006, Apr 8, 2009.

  1. anil2006

    anil2006 Power Member

    Joined:
    Mar 12, 2009
    Messages:
    715
    Likes Received:
    228
    I have a wordpress blog which has categories and subcategories. I have set permalinks to /%postname%/ .
    When ever i click on any category, i get page url in this format:
    hxxp://domain_name.com/category/category_name/

    and when i click on subcategory i get:
    hxxp://domain_name.com/category/category_name/subcategory_name/

    I want to show both above in this format:
    hxxp://domain_name.com/category_name-articles

    So problem is how to do it? is there any plugin for this ? Or what changes in codes required?

    Thanks for you time.
     
    Last edited: Apr 8, 2009
  2. proseospecialists

    proseospecialists Junior Member

    Joined:
    Feb 18, 2009
    Messages:
    120
    Likes Received:
    27
    I'm not sure because I have never used thaT SETUP BUT i USE /%category%/%postname%/ to give me domain.com/mycat/article. maybe /%category%-%postname%/ will work. let me know
     
  3. letusgo

    letusgo Junior Member

    Joined:
    Nov 15, 2008
    Messages:
    199
    Likes Received:
    125
    I think it could solve using .htaccess file but sorry i am not familiar with.
     
  4. anil2006

    anil2006 Power Member

    Joined:
    Mar 12, 2009
    Messages:
    715
    Likes Received:
    228
    it seems you did not read thread carefully.
     
  5. letusgo

    letusgo Junior Member

    Joined:
    Nov 15, 2008
    Messages:
    199
    Likes Received:
    125
    Hehe, come here codex*wordpress*org/Using_Permalinks
    you will know if i read your thread carefully and might get the idea to solve your problem.
     
  6. Haspel

    Haspel Power Member

    Joined:
    Oct 7, 2008
    Messages:
    649
    Likes Received:
    989
    Try this plugin:


     
  7. goodtips

    goodtips Newbie

    Joined:
    Nov 28, 2007
    Messages:
    15
    Likes Received:
    0
    Do not put the / in front when you enter your nice permalink. The Wordpress system will automatically add a / in front. You can enter this:

    %category%-%postname%

    This should work just fine.

    Unless you have some kind of SEO plugin that interfered with the setting. Then, you should check the setting of that plugin. One I could think of is All-In-One-SEO plugin.

    Hope it helps:)
     
  8. sagarpatil

    sagarpatil Regular Member

    Joined:
    Mar 2, 2009
    Messages:
    476
    Likes Received:
    282
    There's a plugin out there which does exactly what you need! go find out on wordpress.org/extend