1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Added AutoBlog to Webmaster Tools, Dropped Completely From Google

Discussion in 'Black Hat SEO' started by zombieshucks, Jul 12, 2010.

  1. zombieshucks

    zombieshucks Registered Member

    Joined:
    Jul 25, 2009
    Messages:
    74
    Likes Received:
    58
    I added one of my autoblogs to Google Webmaster tools by mistake (was adding a lot of sites, slipped off my mind that this one was an autoblog). Within a day of adding it to Webmaster Tools, my ranking dropped significantly (from #15 to #751).

    Its been a week since, so its not a case of Google Dance. I removed the site from Webmaster tools almost a week ago, but the ranking is still hovering around 750.

    What can I do to mitigate this and get my site back up the SERPs? This was a great niche and the site was picking up momentum - would've broken through to the top 5 if I had continued my backlinking strategy (there are over half a million searches for my keyword).

    Any SEO experts care to shed some light on this?
     
  2. zachfogg1

    zachfogg1 Newbie

    Joined:
    Jun 26, 2010
    Messages:
    15
    Likes Received:
    2
    I'm not sure that webmaster tools is your problem.. wouldn't google have that info anyway?

    Is keeping autoblogs off webmaster tools a general practice?
     
  3. zombieshucks

    zombieshucks Registered Member

    Joined:
    Jul 25, 2009
    Messages:
    74
    Likes Received:
    58
    I never add my autoblogs to Webmaster tools. I'm not quite sure if that is the problem, but a drop of 740 ranks all of a sudden with no sign of reversal is weird.

    Before you ask, I did NO mass spam/black hat marketing with this site. I'd built just about a dozen or so links to it, all from EzineArticles (i.e. high quality links).

    That's why I'm perplexed. More so because the niche is awesome and I was about to break through to the first page (the keyword gets almost half a million searches per month)
     
  4. gosu22

    gosu22 Junior Member

    Joined:
    Nov 6, 2008
    Messages:
    104
    Likes Received:
    12
    Just curious, how many hits per day were you getting with rank #14?

    I kind of recommending making the same site with another domain and then doing the same link building campaign, this time don't submit it to webmaster tools.
     
  5. Crixus

    Crixus Regular Member

    Joined:
    Jul 10, 2010
    Messages:
    409
    Likes Received:
    119
    Occupation:
    Jack of all trades, master of a couple.
    Location:
    the ludus
    > I'd built just about a dozen or so links to it, all from EzineArticles (i.e. high quality links)

    All of your links coming from one site is a flag, IMO.
     
  6. ch8878

    ch8878 Elite Member

    Joined:
    Mar 21, 2009
    Messages:
    2,242
    Likes Received:
    428
    Gender:
    Male
    Occupation:
    Gamer
    Location:
    Youtube
    Home Page:
    I never knew you shouldnt add auto blog to webmaster tools can others verifi ?
     
  7. zombieshucks

    zombieshucks Registered Member

    Joined:
    Jul 25, 2009
    Messages:
    74
    Likes Received:
    58
    Not all my links are from EZA. These were the links I'd just built in the past few days. I had links from a variety of sources, blogs, article directories, forums. Nothing fishy about the link pattern. I had a healthy 1600 backlinks amassed over 4-5 months. The backlinking was pure white hat, the only black hat part was the autoblog itself.


    Btw, I'm still no.8 on Bing for the keyword.

    Not much - just around 40. The top position in the search engines is dominated by a MAJOR brand which should be getting more than 60% of the clicks. Still, even no. 2 or 3 for this keyword could've fetched me a healthy 1000+ visitors a day.


    My question now is: can I get the site back up the SERPs (seeing that Bing hasn't yet dropped me) or its not worth the time?