1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

A Couple of WP-O-Matic Technical Issues

Discussion in 'Blogging' started by bcmwp, Jan 23, 2010.

  1. bcmwp

    bcmwp Newbie

    Joined:
    Jan 18, 2010
    Messages:
    4
    Likes Received:
    0
    Hi, everyone. I've really enjoyed browsing this forum, and I'm interested in putting together an autoblog with WP-o-Matic.

    I've had two problems that I've had no luck at all solving, though, and I would appreciate some suggestions, please. I've gone through the tutorials and videos, but these two issues arose:

    1. Somehow, my cron job isn't actually fetching results everytime. I have it set to do one article per hour (it's just a test blog right now), but it only fetches about 2-3 times per day. Usually, it just sits there saying "Next!", even when a cron job comes in. It's not that there are no new articles. It's not even trying to fetch, according to my log. My guess is that it's some sort of synching issue with time zones, but I'm not sure how to fix or even confirm that.

    2. I can't get search feeds to give me any posts at all. I tried a feed like, "http://blogsearch.google.ca/blogsearch_feeds?hl=en&lr=&um=1&q=canadian+politics&ie=utf-8&num=10&output=rss", but when I fetch it, I get nothing, just a red 0. Normal rss feeds, I can get to run. I don't have any guesses as to what the problem is here.

    Thank you for reading my post. I'd really appreciate any suggestions, as there are some sites I'd really like to put together.
     
  2. tee1

    tee1 Junior Member

    Joined:
    Dec 30, 2008
    Messages:
    112
    Likes Received:
    162
    I couldn't get it to work either, so I started using wp robot. works great for now :)
     
  3. jannysoft

    jannysoft Junior Member

    Joined:
    Nov 15, 2009
    Messages:
    144
    Likes Received:
    250
    Location:
    Amsterdam
    Home Page:
    yah i have solved the first problem and the dupe problem ... guys the only way to fetch feeds on time is to use wordpress cron plugins ... but even then you have to have a visitor to your site so the hit from that visiotr can trigger the cronjob to be executed ... i cant remember which plugin i have used but try wp-cron and cron-utopia ...

    about the dupe problem ... there is a plugin which i have downloaded from this forum, but i cant remember the name of the plugin as well i think is some sort of delete duplicate or delete duplicate posts ... its only one php file ... which worked very well for me !

    One hint ... if you feed twitter directly with a plugin or any other social bookmark engine think of alternative ... because the plugin which deletes the duplicate posts is doing so after a posts is made but still simetimes the second post which actually is the duplicate one lands in twitter as well, and when you check back in to your blog admin panel the post doesnt exist. And if the post doesnt exist and somebody clicks on the link from twitter he gets 404 error .. and 99 % of the people are getting mad when they see this pages !
     
  4. bcmwp

    bcmwp Newbie

    Joined:
    Jan 18, 2010
    Messages:
    4
    Likes Received:
    0
    I'm not having any trouble with duplicate posts, just the problems I mentioned above.