1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

3 days trying to figure this, please help

Discussion in 'Blogging' started by sonobby1, Apr 8, 2010.

  1. sonobby1

    sonobby1 Regular Member

    Joined:
    Mar 3, 2009
    Messages:
    236
    Likes Received:
    31
    Location:
    Uk
    Ok so I install a new wordpress for a domain name, install my plugins but only activated wprobot, my theme etc, get wprobot set up, start it to post etc, then when I go and check my live url, I get this error on the right hand side.

    Fatal error: Call to undefined function popular_posts() in /home/sonobby1/public_html/domainname.com/wp-content/themes/Reflux/sidebar.php on line 20

    Ive tried everything I can think off, ive deleted the plugins, and tried again, ive deleted the whole wordpress installation, and installed again. Ive tried different themes, always the same error. One thing though, if I change the theme to the old basic wordpress theme, classic I think it was, then everything is fine.
    But any better themes than I get this error, and its really doing my head in.
    someone please help lol
    Si
     
  2. dearac

    dearac Junior Member

    Joined:
    Nov 15, 2008
    Messages:
    176
    Likes Received:
    165
    are you sure you're not missing a plugin that the theme requires?
     
  3. Grizzy

    Grizzy Senior Member

    Joined:
    Nov 11, 2008
    Messages:
    919
    Likes Received:
    999
    Well it looks like your theme wants to use the wp popular posts plugin in its sidebar. Do you have that plugin installed?
     
  4. sonobby1

    sonobby1 Regular Member

    Joined:
    Mar 3, 2009
    Messages:
    236
    Likes Received:
    31
    Location:
    Uk
    Grizzy I noticed that so I found the plugin, installed it, and still the error.
    dearac, thats a good question actually. I wanted to follow shezblogs blog guide, and he sugests around 10 different plugins, and they are different plugins to what I normally put on the theme.
    I wonder if its a plugin im missing, umm
    But I dont understand that, do you need plugins to make a theme to work, I not heard of that?
     
  5. dearac

    dearac Junior Member

    Joined:
    Nov 15, 2008
    Messages:
    176
    Likes Received:
    165
    well if you would like me to take a look just pm me. I fix those kind of errors for people all the time.

    if you don't want me to look, pm me the link to get the theme and I'll install it on my local host to see if I have the same problems and find you a fix.
     
    • Thanks Thanks x 1
  6. sonobby1

    sonobby1 Regular Member

    Joined:
    Mar 3, 2009
    Messages:
    236
    Likes Received:
    31
    Location:
    Uk
    its sorted now thanks to dearac, thanks given
    Si
     
    • Thanks Thanks x 1
  7. junaidb

    junaidb Newbie

    Joined:
    Mar 26, 2010
    Messages:
    3
    Likes Received:
    0
    i would suspect that maybe some files are virus infected.
    i had this error some time back and i just deleted everything and reloaded the blog from scratch...that worked for me.
    i figured it would take me 20mins to reload from scratch instead of busting my ass figuring it out....
     
  8. Quicksilver.FX

    Quicksilver.FX Newbie

    Joined:
    Feb 9, 2009
    Messages:
    22
    Likes Received:
    2
    Occupation:
    CEO of Nexon America
    Yes, because you can infect script files... (.html, .php, .cgi, and so on).:rolleyes:

    Don't say things you are unsure of, people read forums for information.