1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

1/10 Quality Score?

Discussion in 'Adwords' started by kevin198x, Jan 3, 2009.

  1. kevin198x

    kevin198x Junior Member

    Joined:
    Nov 12, 2008
    Messages:
    141
    Likes Received:
    110
    I set up one of my landing pages which I've used before and have received great quality scores. Now, when I create my campaign, my main keyword gets a 1/10 quality score but the rest are all 7/10 even though they're less relevant. It accepts my bid but says "Ads rarely show due to low quality score".

    What's going on and why does Google hate me?
     
  2. arbitorx

    arbitorx Newbie

    Joined:
    May 16, 2008
    Messages:
    48
    Likes Received:
    3
    welcome to the wonderful world of adwords..
     
  3. macmastermike

    macmastermike Junior Member

    Joined:
    Apr 2, 2008
    Messages:
    116
    Likes Received:
    33
    Location:
    Grand Duchy of Bavaria
    ok that's quite uncommon... are you doing adsense-arbitrage? or any other stuff google doesn't like (TOS)?

    try creating the campaign in a new campaign/adgroup, bid high the first week... i've never seen a 1/10... actually it's quite hard to get a qs under 6/10...

    if it's still not working call the adwords-support and ask them why you receive that low qs. but if you do blackhat stuff with adwords better don't call them (like if an editor clicks throughy my account i'm not quite sure if they'll deactivate some of my campaigns...)
     
    • Thanks Thanks x 1
  4. longdrv4u

    longdrv4u Newbie

    Joined:
    Sep 28, 2008
    Messages:
    30
    Likes Received:
    3
    Occupation:
    IM
    Location:
    North Carolina
    Home Page:
    I have never got 1/10 quality score. What I have gotten is $10.00 to get on first page when it used to be .45 cents.
    Try putting your landing page in keyword tool and see what keywords big g finds relevant

    you could also try different add variation or
    delete the keyword then add it back in a couple of days
     
  5. premiumsource

    premiumsource Senior Member

    Joined:
    Apr 20, 2008
    Messages:
    863
    Likes Received:
    1,164
    Location:
    Paradise Island
    maybe your click through rate is horrific.
     
  6. kevin198x

    kevin198x Junior Member

    Joined:
    Nov 12, 2008
    Messages:
    141
    Likes Received:
    110
    This is a brand new campaign. I've tried it on three separate domains and three different campaigns with different ad copies and two different landing pages. I would understand if it gave me 5/10 or so and asked for a higher bid but 1/10 and accepting my bid? It must mean that I'm violating some rule but it doesn't say what and this landing page works fine for other campaigns..
     
  7. justdude

    justdude Regular Member

    Joined:
    Dec 17, 2008
    Messages:
    220
    Likes Received:
    72
    what's your overal account QS ? If you have low QS in other campaign that could be reason. Maybe these keywords aren't related in anyway with your page. But probably you got problems with low QS in other campaign in this account and it's mean for you you got low QS on plenty new things.
     
  8. marioland

    marioland Registered Member

    Joined:
    Dec 8, 2008
    Messages:
    80
    Likes Received:
    15
    It's weird, I agree. I had a kw in a campaign with QS 7, I have deleted it and add it back again after 2 days, and got QS 4, for the same kw. Who knows what happen with the campaigns...