1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

yahoo site explorer ~ loads of back links but not mine?!

Discussion in 'White Hat SEO' started by zimsabre, Apr 4, 2011.

  1. zimsabre

    zimsabre Regular Member

    Joined:
    Nov 11, 2010
    Messages:
    255
    Likes Received:
    174
    Ok strange one here, I made a new site a week ago nothing much. it has 1 article ranked number 56 on google.

    Im using wordpress, the basic twenty ten theme, and i have done no "seo backlinking" apart from 1 hubpages.

    Yet yahoo search is showing up over 100 backlinks to my site all from 1 site? i cant find my link on this particular site so im stumped. all of the backlinks are Do-follow aswell.

    Why would this be?
     
  2. master-of-backlinks

    master-of-backlinks Regular Member

    Joined:
    Nov 29, 2010
    Messages:
    245
    Likes Received:
    544
    Location:
    USA
    Home Page:
    Couod just be a glitch, Yahoo site explorer has done this to me before as well, Id say wait a couple of days, and then check it you will see your correct links. Wish you the best :)
     
  3. zimsabre

    zimsabre Regular Member

    Joined:
    Nov 11, 2010
    Messages:
    255
    Likes Received:
    174
    Today there are well over 500 back links from this one domain?
    Any ideas?
     
  4. zimsabre

    zimsabre Regular Member

    Joined:
    Nov 11, 2010
    Messages:
    255
    Likes Received:
    174
    Word press dash board has been flodded now aswell :S i have emailed the admin over at their site to find out whats going on.