1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

wp-o-matic images don't display right

Discussion in 'Blogging' started by Nauthiz666, Mar 24, 2009.

  1. Nauthiz666

    Nauthiz666 Senior Member

    Joined:
    Nov 14, 2008
    Messages:
    851
    Likes Received:
    80
    I have my rss feed image showing up as a discription only with a link, and no image showing. How can i fix this so the image shows up properly? Its basically just giving me the caption of the photo with a link.
     
  2. The Scarlet Pimp

    The Scarlet Pimp Jr. VIP Jr. VIP Premium Member

    Joined:
    Apr 2, 2008
    Messages:
    788
    Likes Received:
    3,129
    Occupation:
    Chair moistener.
    Location:
    Cyberspace
    perhaps the problem is the rss link itself. have you tried it in "feedwordpress"?
     
  3. Nauthiz666

    Nauthiz666 Senior Member

    Joined:
    Nov 14, 2008
    Messages:
    851
    Likes Received:
    80
    Nope i haven't the wierd thing about this is, i see another website pulling the same rss with wpomatic and it posts the images, yet mine doesn't not sure why lol.
     
  4. The Scarlet Pimp

    The Scarlet Pimp Jr. VIP Jr. VIP Premium Member

    Joined:
    Apr 2, 2008
    Messages:
    788
    Likes Received:
    3,129
    Occupation:
    Chair moistener.
    Location:
    Cyberspace
    while you're solving the problem, try running the feed thru feedwordpress in the meantime.
    if it posts images, then use that until you figure out why wpom isn't working correctly.

    i switched to fwp and so far it's posting both text and images into the correct categories.
     
  5. trapmuzik

    trapmuzik Junior Member

    Joined:
    Mar 20, 2009
    Messages:
    192
    Likes Received:
    22
    you do realize that by default wp-o-matic will only pull images if they exist in the content tag of the item in the feed. alot of websites also use alternate tags in their feeds such as image or thumbnail tags (i.e. <image>url</image>)
     
  6. rawasch

    rawasch Junior Member

    Joined:
    Sep 15, 2008
    Messages:
    142
    Likes Received:
    663
    Do you know how we can get WP-o-matic to post the images in that case?
     
  7. trapmuzik

    trapmuzik Junior Member

    Joined:
    Mar 20, 2009
    Messages:
    192
    Likes Received:
    22
    yes. you have to modify the code to do it. it does not come with a way to configure this out of the box.
     
  8. rawasch

    rawasch Junior Member

    Joined:
    Sep 15, 2008
    Messages:
    142
    Likes Received:
    663
    Did you do that? And if so would you be willing to share your modifications? That would be great!