1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WP- Global Translator and Sitemap Gen

Discussion in 'Blogging' started by fakeplastictrees, Jan 11, 2009.

  1. fakeplastictrees

    fakeplastictrees Registered Member

    Joined:
    Aug 15, 2008
    Messages:
    53
    Likes Received:
    8
    Hey all

    I'm working on my autoblogs and I installed global translator and the google sitemap generator tools. However, the google sitemap generator tool will not index the pages in the other languages. Before you ask, yes I have it selected to work with google sitemap gen and yes I have "work in background" selected on google sitemap gen. Still no success. Any thoughts?
     
  2. royalmice

    royalmice BANNED BANNED

    Joined:
    Aug 23, 2007
    Messages:
    1,186
    Likes Received:
    982
    I suggest adding it manually. At the bottom of the sitemap settings there is a option of adding pages manually, i suggest adding the top level page and let the search engines follow it from there, for example my-domain.com/de/ or my-domain/fr/
     
    • Thanks Thanks x 1
    Last edited: Jan 11, 2009
  3. royalmice

    royalmice BANNED BANNED

    Joined:
    Aug 23, 2007
    Messages:
    1,186
    Likes Received:
    982
    Thanks for the thanks :) I meant to say that you should add all the top level different languages that you have, so if you have 12 languages then you need to add them all
     
    • Thanks Thanks x 1
  4. fakeplastictrees

    fakeplastictrees Registered Member

    Joined:
    Aug 15, 2008
    Messages:
    53
    Likes Received:
    8
    Yeh, I got what you meant. Tried it and it still isn't showing up in the sitemap for some reason.... I know not all of them have been translated yet, but some have and aren't showing up
     
  5. reinie

    reinie Elite Member

    Joined:
    Jan 16, 2009
    Messages:
    1,574
    Likes Received:
    1,040
    Hi guys
    I am also still looking for a solution to this.
    I had hostgator on the phone but they couldnt figure it out either.

    My sitemap has errors when I enable Global Translator.
    I did use "buil in background" and I chose "Integrate with search engine"
    I also built the sitemap manually for the first time, but nothing help...

    Whn the sitemap built, it just shows a white page, and My Google Webmaster detects an error with the sitemap. It gives similar error message in WP-admin as OP described.

    Any help would be greatly appreciated.