1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Wordpress Issue two empty metatags (keyword,desc) appearing on every page

Discussion in 'Blogging' started by aidenhera, Feb 21, 2017.

  1. aidenhera

    aidenhera Elite Member

    Joined:
    Nov 30, 2016
    Messages:
    2,037
    Likes Received:
    449
    Gender:
    Male
    First of all I wanna say I have 3 websites with the same wordpress theme and im not a complete noob.

    I have problem because on one of these themes i have empty desc and keyword metatags on everypage/post apparing BEFORE all in one meta tags.

    i cant edit them nor remove. I looked header.php there are not there idk

    This happened in just one of my sites.

    What i did differently was that I copied plugins through updraft from previous sites so maybe they didnt uninstall properly? i had couple seo plugins and already uninstalled the bad ones
     
  2. newsworldinside

    newsworldinside Junior Member

    Joined:
    Jun 23, 2014
    Messages:
    138
    Likes Received:
    32
    Gender:
    Male
    Occupation:
    Web Developer, WordPress Frontend Expert
    Location:
    Back to the Future
    Check you theme's settings, there might be an option to enable or disable SEO. And it seems you're also using another plugin for meta.
     
    • Thanks Thanks x 1
  3. aidenhera

    aidenhera Elite Member

    Joined:
    Nov 30, 2016
    Messages:
    2,037
    Likes Received:
    449
    Gender:
    Male
    Uh you were right there was another plugin causing the problem BUT that plugins has NOTHING related to SEO and i need it anyways... ill try to edit plugin code to remove the useless feature, or ill look for other plugin.

    I think the plugin was built on some other plugin..
    I removed
    Code:
                    var wpu_meta_title = document.getElementById('dws_meta_title').value;
                    var wpu_meta_desc = document.getElementById('dws_meta_desc').value;
                    document.getElementById('dws_title_charcount').innerHTML = wpu_meta_title.length;
                    document.getElementById('dws_meta_description_charcount').innerHTML = wpu_meta_desc.length;
    
                    document.getElementById('wpuseotitle').innerHTML = (wpu_meta_title != "") ? wpu_meta_title : wpu_meta_title_default;
                    document.getElementById('wpuseodesccontent').innerHTML = (wpu_meta_desc != "") ? wpu_meta_desc : wpu_meta_desc_default;
    
    from the plugin and its now working nicely, wow its better to care what u install to wordpress rotfl
     
    Last edited: Feb 21, 2017