1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Word Press 2.6 Released today-Upgrading Existing Blogs?

Discussion in 'Blogging' started by Mudvaine, Jul 16, 2008.

  1. Mudvaine

    Mudvaine Registered Member

    Joined:
    Apr 6, 2008
    Messages:
    64
    Likes Received:
    79
    Location:
    Disney World
    Hey guys I'm a semi-noob, (not quite as wet behind the ears as I was when I first starting visiting here) and my question is this:

    After reading the 2.6 WP upgrade guidelines I'm a bit nervous about upgrading my current WP blogs. :confused:

    Is anyone else have the same concern? Fortunately I only have 3 up right now so I figured just starting some new ones under the new platform was the best idea.

    Thoughts?
     
  2. red2004

    red2004 Junior Member

    Joined:
    Aug 17, 2007
    Messages:
    129
    Likes Received:
    28
    wordpress is easy download the new upgrade file then replace with the old one.

    it will automatically do it for you..
     
  3. oldenstylehats

    oldenstylehats Elite Member Premium Member

    Joined:
    Apr 10, 2008
    Messages:
    1,893
    Likes Received:
    1,196
    Check and see if your plugins have been upgraded. Many haven't and won't work. Also, if you've already upgraded and somehow borked the installation or didn't backup, here is a link to WordPress 2.5.1:
    Code:
    http://wordpress.org/wordpress-2.5.1.zip
     
  4. battman323

    battman323 Regular Member

    Joined:
    Aug 10, 2007
    Messages:
    449
    Likes Received:
    395
    Occupation:
    Extortionist
    Location:
    None of your damn business
    So far only one of my plugins isn't working, but it'll be upgraded quickly and isn't SUPER important. What pisses me off is that it takes me forever to update all my blogs.
     
  5. sengko

    sengko Newbie

    Joined:
    Apr 2, 2008
    Messages:
    5
    Likes Received:
    0
    Battman, i also faced the same situation like you. one of my plugin ( robot-meta) not working, is it same like yours?
     
  6. breakfree

    breakfree Registered Member

    Joined:
    Feb 19, 2008
    Messages:
    78
    Likes Received:
    10
    Occupation:
    in boston
    Location:
    at boston
    Home Page:
    So far, so good for me, I'm not using the above mentioned plugin though...
     
  7. fizfaziq

    fizfaziq Newbie

    Joined:
    Dec 25, 2007
    Messages:
    37
    Likes Received:
    7
    If you've no issue with current version and not urgently required to update, then just wait till all the plugin you're using compatible with the new version.
    Sometimes the new release also has a few bugs and might need us to update again later (i.e 2.6.1 and so on..)
    So better to do it when they release the fully stable version.. may be have to wait till a few months..
    At least, that's for me..
     
  8. The Lazy Pig

    The Lazy Pig Jr. VIP Jr. VIP Premium Member

    Joined:
    Apr 10, 2008
    Messages:
    161
    Likes Received:
    1,532
    Occupation:
    Mud safe keeper.
    Location:
    a farm, perhaps a sty.
    Home Page:
    Just wait a couple of weeks for everything to be fixed then upgrade. Or you can be like me and use that as an excuse for laziness. :)
     
  9. Mudvaine

    Mudvaine Registered Member

    Joined:
    Apr 6, 2008
    Messages:
    64
    Likes Received:
    79
    Location:
    Disney World
    Yes I was thinking the same thing and waiting before I make any changes. The new features on 2.6 look pretty cool I have to admit.

    I'm using host gator for my sites and I'm about to look and see if their still showing the 2.5 or have upgraded yet in their fantastico. I'm going to start some new ones and use the 2.6. I'll keep you abreast of any feedback.
     
  10. battman323

    battman323 Regular Member

    Joined:
    Aug 10, 2007
    Messages:
    449
    Likes Received:
    395
    Occupation:
    Extortionist
    Location:
    None of your damn business
    the upgrade seems stable, the pinging seems to have been changed a bit which is why my pinging control plugin isn't working is all

    i like how they're making the updates automatically downloadable within the script

    remember how it used to be a pain to upgrade all your plugins by hand?
     
  11. goonieguhu

    goonieguhu Junior Member

    Joined:
    Apr 8, 2008
    Messages:
    169
    Likes Received:
    32
    Not sure if I can completely trust the short answer provided, but here is a recent question/answer on WP 2.6 and pinging:


    Do I need a ping optimizer in WP 2.6?

    1. joelbacklund
    Member
    Posted 1 day ago #

    Do I really need a plug-in like MaxBlogPress Ping Optimizer in WP 2.6 to create a ping when I post a "future post" or to prevent WP of ping multiple times when I edit an old post?

    2.

    Otto42
    Moderator
    Posted 1 day ago #

    No, WordPress 2.6 deals with pings correctly.
     
  12. oldenstylehats

    oldenstylehats Elite Member Premium Member

    Joined:
    Apr 10, 2008
    Messages:
    1,893
    Likes Received:
    1,196
    Yeah, the new way the deal with plugins is one of my favorite additional features they've added. I think they are definitely moving in the right direction. Even though it would be a bit complicated, I'm hoping they integrate a similar feature for the CMS itself. That would be nice.
     
  13. Mudvaine

    Mudvaine Registered Member

    Joined:
    Apr 6, 2008
    Messages:
    64
    Likes Received:
    79
    Location:
    Disney World
    Well just to be safe I think I'll wait a few weeks before i upgrade my existing WP blogs lol.
     
  14. tata7171

    tata7171 Registered Member

    Joined:
    Apr 27, 2008
    Messages:
    65
    Likes Received:
    171
    Location:
    some place hot
    try to use Wordpress Automatic Upgrade plugin. i've used it, havent got any problems on my blogs.
     
    • Thanks Thanks x 1
  15. Mudvaine

    Mudvaine Registered Member

    Joined:
    Apr 6, 2008
    Messages:
    64
    Likes Received:
    79
    Location:
    Disney World
    Yeah so that was some totally killer help tata. That was a total snap! So far all of my plug ins work great too! Thanks!

    "Man i love this forum."
     
  16. starstreet

    starstreet Newbie

    Joined:
    Jan 4, 2008
    Messages:
    41
    Likes Received:
    319
    just backup all your wp files.. and start delete some file..

    do not delete
    wp-content
    robots.txt
    config.php
    index.php
    .htaccess

    if in your wp-includes have language files.. do not delete.. the whole wp-includes just delete inside wp-includes but exclude the lang or language file.

    the rest of the folder i not mention you can delete..

    after download new version of wp.. extract and you can upload it to your hosting.. but some people upload the wp-config-sample too..
    I do not upload it cos there is will be a problem..
    but please upload the wp-content too.. and just overrite the files if they ask to.

    in case there is some problem you still have the backup folder.. so that's why you need to do BACKUP.
     
  17. catman08

    catman08 Junior Member

    Joined:
    Jan 11, 2008
    Messages:
    171
    Likes Received:
    109
    Occupation:
    IM
    Location:
    Europe
    guys .. can't you use the ugrade function of cpanel?
     
  18. rjhere

    rjhere BANNED BANNED

    Joined:
    Jun 9, 2008
    Messages:
    486
    Likes Received:
    117
    Wordpress 2.6 is a great upgrade but as I just found out they disabled the remote posting capability by default which really sucks cause you can't use auto posting tools anymore unless you enable this.

    So when you install make sure you enable this if you are wanting to use third party auto posting packages.
     
  19. Mudvaine

    Mudvaine Registered Member

    Joined:
    Apr 6, 2008
    Messages:
    64
    Likes Received:
    79
    Location:
    Disney World
    Good to know Rj Thanks!