1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Woocommerce knowledge? Answer a quick question and earn $10

Discussion in 'Hire a Freelancer' started by rapidecommerce, Jan 20, 2014.

  1. rapidecommerce

    rapidecommerce Jr. VIP Jr. VIP Premium Member

    Joined:
    Oct 3, 2010
    Messages:
    453
    Likes Received:
    109
    Hi All

    I am trying to change the alt tag and title tag of the featured images that appear on Woocommerce product category and product pages. At the moment they default to the category name, but I want to change that.

    If you can have a quick glance at my site and tell me which file I need to edit and how, I'll drop a nice easy $10 into your Paypal account.

    Prob a 2 minute job for someone who knows this shit better than me :)
     
  2. ash1ey

    ash1ey BANNED BANNED

    Joined:
    Jul 21, 2006
    Messages:
    320
    Likes Received:
    144
    If I remember correctly when you add images in to woocommerce you do it via the default wordpress media manager? In which case you can change the alt tags and title tags from within there.

    Go to http://www.yoursite.com/wp-admin/upload.php and click edit next to the picture you want to change the tags for.
     
    Last edited: Jan 20, 2014
  3. rapidecommerce

    rapidecommerce Jr. VIP Jr. VIP Premium Member

    Joined:
    Oct 3, 2010
    Messages:
    453
    Likes Received:
    109
    Hi Ashley

    That is how you upload images to the site, but unfortunately Woocommerce overwrites any pre-specified alt and title tags that were attached to the image in the library.

    There will be a .php file somewhere that needs to be edited. All I want to do is tag 2 words onto the end of the auto-generated title and alt tags
     
  4. ash1ey

    ash1ey BANNED BANNED

    Joined:
    Jul 21, 2006
    Messages:
    320
    Likes Received:
    144
    Strange, I've just looked in to my website and it appears that on my homepage, the alt image tags for the products in the html code is being pulled from the alt tags I specified within the media manager of wordpress (which by default is the name of the image uploaded).

    Maybe it has something to do with the woocommerce theme you are using.

    Could you possibly PM me with your site so I can see an example?