1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Why are my Page Titles in the SERPs different from AIO SEO plugin info?

Discussion in 'White Hat SEO' started by dantob, Sep 12, 2011.

  1. dantob

    dantob Power Member

    Joined:
    Sep 17, 2010
    Messages:
    518
    Likes Received:
    26
    I noticed recently that for some of my sites that the home page is ranking in the SERPs for it's keyword the title of the page that shows in the SERPs is not what I have in the All In One SEO plugin. It seems to just be using the first part of description and not the rest. So if I have in my plugin for the homepage title to be "Blue Small Widgets - Best Small Widgets" then in the SERPs it just shows up as "Blue Small Widgets" and not the rest.

    For another site it is just showing the title for example like "Blue small widgets" and not even the way I have it in the plugin with first letter being all CAPs of each word.

    Could there be something wrong with the plugin or what? Or is google doing something with my page titles?

    Any feedback?
     
  2. milian

    milian Power Member

    Joined:
    Jan 9, 2010
    Messages:
    515
    Likes Received:
    69
    Occupation:
    SEO stuff
    Location:
    Around
    is the keyword in the URL? Some times google does indeed just show a keyword as the title instead of the actual title tag.

    this happens with my site

    e.g

    my URL might be:

    www.ultimate-widgets.com

    and my title tag is:

    Promotional blue widgets- Custom Branded widgets

    but if i search for just ultimate widgets google just displays the title tag as ultimate widgets.

    I guess google just sometimes decides it has a better title than your title tag so uses that. You could be experiencing this.
     
  3. dantob

    dantob Power Member

    Joined:
    Sep 17, 2010
    Messages:
    518
    Likes Received:
    26
    Yes for these sites the keyword I'm searching for is also the EMD. Anyway to fix this issue? I did not have this issue before. The only thing that could be a cause of this that might have triggered this is the sites had expired as far as domain name is concerned and I renewed them a day later again. For the 12-24 hours the sites were down.

    But when I view the source code for the homepage the title tags are correct. It's only when checking the SERPs that it only shows my keyword for the title tag when I'm searching for that keyword.
     
    Last edited: Sep 14, 2011
  4. dantob

    dantob Power Member

    Joined:
    Sep 17, 2010
    Messages:
    518
    Likes Received:
    26
    Anyone have any feedback on this issue?