what is wrong with my theme??

Discussion in 'BlackHat Lounge' started by kikiriki, Dec 27, 2009.

  1. kikiriki

    kikiriki Power Member

    Joined:
    Dec 18, 2008
    Messages:
    751
    Likes Received:
    228
    i have a site with the wp maxine theme and i never had a problem with the
    theme until the last month, i noticed that on FF my theme shows up as it should
    in the middle of the screen and a black background on the sides, but in IE and Safari it is showing up on the left side of the screen and all the right side is a black background, i did not had this problem before but now i dont know what
    to do can you help me??
     
  2. kikiriki

    kikiriki Power Member

    Joined:
    Dec 18, 2008
    Messages:
    751
    Likes Received:
    228
    in other words what i am saying is that my site moved to the left side of the screen on IE
    and on FF its working well.
    could this be an html problem?? or do i need do add something on IE so it ill show up as
    it should???
     
  3. kikiriki

    kikiriki Power Member

    Joined:
    Dec 18, 2008
    Messages:
    751
    Likes Received:
    228
    guys can you help me?? or at least tell me where can i find out what to do?
     
  4. richjerkoff

    richjerkoff Junior Member

    Joined:
    Apr 7, 2008
    Messages:
    159
    Likes Received:
    80
    Location:
    UK
    It's probably something to do with the CSS not centering the page properly.

    I don't know this theme but most themes use this to center a page


    margin:0 auto;
    text-align:center; /*this makes it work in IE*/

    Then to make the text in the content area align correctly, try

    text-align:left;

    I use the Firebug addon to troubleshoot CSS problems
     
  5. kikiriki

    kikiriki Power Member

    Joined:
    Dec 18, 2008
    Messages:
    751
    Likes Received:
    228
    firebug is for FF and my problem is with IE, or if i center it for FF it will be centered in IE??
     
  6. kikiriki

    kikiriki Power Member

    Joined:
    Dec 18, 2008
    Messages:
    751
    Likes Received:
    228
    ok i added firebug but i dont know how to use it, can you help?
    do i need to do the changes on the site's landing page or in my wp-admin??
    please guide me.
     
  7. richjerkoff

    richjerkoff Junior Member

    Joined:
    Apr 7, 2008
    Messages:
    159
    Likes Received:
    80
    Location:
    UK
    Without knowing what your css file contains I can't offer any advice on what you have to do because each one is specific to a theme.

    You need to find your css file for the theme and amend the code. If you don't know what you are doing then you might screw your site up. Make a backup of you css file so that you can restore it back to normal if you make mistakes.