1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Website Ranks only in US

Discussion in 'Black Hat SEO' started by francis1017, Mar 23, 2015.

  1. francis1017

    francis1017 Elite Member

    Joined:
    Feb 26, 2013
    Messages:
    1,506
    Likes Received:
    349
    Hello Everyone,

    I have this website that only ranks in US - Rank 24 Page 3(checked it using US IP in google and my rank tracker).
    But when I try to use my browser and other countries IP like Netherlands I can't find it in top 100.

    I am targeting wordwide since my PBN (using to rank) are .com, .net and .org (no specific country targeted).
    Anyone having this kind of problem? Please advice.
    Thanks!
     
  2. WebTG

    WebTG Jr. VIP Jr. VIP

    Joined:
    Mar 18, 2015
    Messages:
    592
    Likes Received:
    150
    Hosting of your website also matter for website to rank in the particular country, if you are doing local listing then it is most likely to not rank outside of that country. I have seen a local business website which ranks in a particular city and not in other city same country for the same keywords.
     
    • Thanks Thanks x 1
  3. RuthSam

    RuthSam Jr. VIP Jr. VIP Premium Member

    Joined:
    Mar 19, 2010
    Messages:
    3,814
    Likes Received:
    979
    Gender:
    Male
    Home Page:
    hmmm strange... we had some simlar problems, in our case it helped to get links from European websites (high authority). After a few months the website started to rank at Google UK and a few other countries.. We switched hosting as well for 7 months ago from Europe to a German provider! I'm not sure if that had any impact we did because of speed.
     
    • Thanks Thanks x 1
  4. francis1017

    francis1017 Elite Member

    Joined:
    Feb 26, 2013
    Messages:
    1,506
    Likes Received:
    349
    Thanks! Will transfer my site from another hosting, I am using an unknown offshore hosting which I think is the problem (IP I guess). Will post again here if it helps..