Visitors to my site get 404 error

Discussion in 'Black Hat SEO' started by fatjack'sblackhat, Aug 8, 2013.

  1. fatjack'sblackhat

    fatjack'sblackhat Power Member

    Joined:
    Jul 16, 2008
    Messages:
    624
    Likes Received:
    131
    Occupation:
    college student
    Location:
    Florida
    I changed a page name on my site so now Im getting messages that visitors to my site are getting 404 errors when they visit my site. Looking further, I see they are referred by google and google still has my old page name indexed so visitors click on it and there is nothing there.

    I hope I have explained this clearly enough. Now, is there a way to get those links in google to be updated with my new page name and url? Any insight on this would be very helpful, I can't find this specific issue on the forums..
     
  2. HelloInsomnia

    HelloInsomnia Jr. Executive VIP Jr. VIP

    Joined:
    Mar 1, 2009
    Messages:
    1,831
    Likes Received:
    2,947
    301 redirect.
     
    • Thanks Thanks x 1
  3. HerpDerpSlerp

    HerpDerpSlerp Power Member

    Joined:
    Mar 19, 2013
    Messages:
    778
    Likes Received:
    625
    open .htaccess

    Code:
    # Redirect old file path to new file path 
    Redirect /olddirectory/oldfile.html http://example.com/newdirectory/newfile.html
     
    • Thanks Thanks x 1
  4. fatjack'sblackhat

    fatjack'sblackhat Power Member

    Joined:
    Jul 16, 2008
    Messages:
    624
    Likes Received:
    131
    Occupation:
    college student
    Location:
    Florida
    This is exactly correct. I was looking more into this and found this that explains it:
    HTML:
    http://www.bruceclay.com/blog/2007/03/how-to-properly-implement-a-301-redirect/
     
  5. fatjack'sblackhat

    fatjack'sblackhat Power Member

    Joined:
    Jul 16, 2008
    Messages:
    624
    Likes Received:
    131
    Occupation:
    college student
    Location:
    Florida
    I messed up my htaccess and fixed it.. Now my old link redirects to the right page in google chrome but not in FireFox. How can I fix this problem in firefox?
     
  6. dinkish

    dinkish Power Member

    Joined:
    Apr 19, 2013
    Messages:
    689
    Likes Received:
    159
    Don't redirect it with a http_user_agent and you should be fine.
     
    • Thanks Thanks x 1
  7. fatjack'sblackhat

    fatjack'sblackhat Power Member

    Joined:
    Jul 16, 2008
    Messages:
    624
    Likes Received:
    131
    Occupation:
    college student
    Location:
    Florida
    Ok, I think I fixed the problem. Thanks Dinkish! :)

    Now my 404 error checker is showing errors for pictures that i changed the names of to have alt text and be more seo friendly. I guess users are being directed to the old image and its not there which I guess would mean though the page is displaying for them, the pictures aren't correct. Will this problem fix itself in time or do I need to change something?