1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Unable to retrieve ID...

Discussion in 'Instagram' started by BigTroll, Jan 1, 2016.

  1. BigTroll

    BigTroll Jr. VIP Jr. VIP

    Joined:
    Oct 15, 2014
    Messages:
    1,899
    Likes Received:
    735
    Occupation:
    CPA
    Location:
    ROMANIA
    This shit annoys me as hell. 20-30% of scraped users can't be folllowed because of this shitty error. Am I the single one?
    I have this problem on all vps's with almost all accs: JdMcs6y.png
     
    Last edited: Jan 1, 2016
  2. txholdem

    txholdem Elite Member

    Joined:
    Feb 23, 2009
    Messages:
    1,718
    Likes Received:
    209
    luckily i dont have that problem, among other problems like blank captions and crashing.
     
  3. longdouble

    longdouble Regular Member

    Joined:
    Jun 15, 2015
    Messages:
    411
    Likes Received:
    81
    The problem you're getting is not related to your VPS. It is your bot to blame. It does not understand server's reply and just spits generic error.

    Second, the bot is coded/configured incorrectly because you have only usernames without accociated user IDs. In real world usernames ALWAYS go along with user IDs.
     
  4. HoNeYBiRD

    HoNeYBiRD Jr. VIP Jr. VIP

    Joined:
    May 1, 2009
    Messages:
    7,316
    Likes Received:
    8,281
    Gender:
    Male
    Occupation:
    Geographer, Tourism Manager
    Location:
    Ghosted
    it's a followliker log, i'm not sure if you realized it or not, but the lack of the user IDs is the problem, not because what you said, that the bot would be coded incorrectly, but because it's just unable to scrape the user IDs for some reason in 20-30% of the cases for OP, it doesn't happen every time, as you can see another user doesn't have the problem, so it must be a user error (if it's not the VPS then it can be too short delays, too many accs on the same ip, too many simultaneous ip connections etc) or else we will have a lot more threads like this taking into account that how many forum users own and use the tool

    to OP: if it doesn't happen when you run the bot on your machine, obviously it has something to do with the VPS, contact FL support, they might have an idea what causes this, if it happens there too, then it's your accs/settings
     
    • Thanks Thanks x 2
    Last edited: Jan 1, 2016
  5. BigTroll

    BigTroll Jr. VIP Jr. VIP

    Joined:
    Oct 15, 2014
    Messages:
    1,899
    Likes Received:
    735
    Occupation:
    CPA
    Location:
    ROMANIA
    Everybody knows that the FL support is full of shit. They told me that it's because of the accounts, users was scraped before and they disabled their accounts after. So, that's the conclusion, FL can not get the ID because the usernames doesnt exist.
    Those motherfuckers didn't even checked my screenshot, all users are good, lol.
     
  6. HoNeYBiRD

    HoNeYBiRD Jr. VIP Jr. VIP

    Joined:
    May 1, 2009
    Messages:
    7,316
    Likes Received:
    8,281
    Gender:
    Male
    Occupation:
    Geographer, Tourism Manager
    Location:
    Ghosted
    yea, that can't be the explanation, but does it happen when you run the bot on your machine or only the VPS?

    i'm thinking maybe it's a scraping limitation imposed by ig, not sure, try to adjust/increase your delays or start a new account from a fresh ip, don't run any more account on the same ip and see if the problem will come up with that too
     
  7. longdouble

    longdouble Regular Member

    Joined:
    Jun 15, 2015
    Messages:
    411
    Likes Received:
    81
    The problem is directly IG-side related. Recently they limited one's ability to scrape users in a very tricky way. It does not affect normal users, but botters suffer. That's why I said: FL cannot handle server reply and gives a generic error. I know it because I scrape users in huge quantities per day and have hit the limit it among the first.

    I've changed the algo of my bot and should be back on track to same quantities in a matter of a week. FL botters will face difficulties to adjust.
     
    • Thanks Thanks x 1
  8. HoNeYBiRD

    HoNeYBiRD Jr. VIP Jr. VIP

    Joined:
    May 1, 2009
    Messages:
    7,316
    Likes Received:
    8,281
    Gender:
    Male
    Occupation:
    Geographer, Tourism Manager
    Location:
    Ghosted
    so i guess one solution would be to increase the delay between two scraping actions, obviously you'll be able to scrape less this way, so you'll need to use more accounts (from different ips) to be able to scrape the same amount as before, but maybe you figured out something else :)
     
  9. Neon

    Neon Jr. VIP Jr. VIP

    Joined:
    Nov 3, 2013
    Messages:
    2,865
    Likes Received:
    6,978
    Gender:
    Male
    Occupation:
    Traveling the world
    Location:
    Berlin
    ABSOLUTELY the same problem here OP ! I've bought the bot this week. It was running fine 1 day and since then it started giving me this error.
    How I'm fixing it ?
    Restarting the software ...
    It will be nice if FL support can add the feature stated above + some kind of notification when there is an error, cuz I can not monitor it 24/7.
     
    • Thanks Thanks x 1
  10. BigTroll

    BigTroll Jr. VIP Jr. VIP

    Joined:
    Oct 15, 2014
    Messages:
    1,899
    Likes Received:
    735
    Occupation:
    CPA
    Location:
    ROMANIA
    Guys, it have nothing to do with scraping.
    I have manually imported my scraped users list, I only do follow :(
     
  11. SalesForce

    SalesForce BANNED BANNED

    Joined:
    Dec 28, 2015
    Messages:
    57
    Likes Received:
    16
    Proxys not working properly?
     
  12. Neon

    Neon Jr. VIP Jr. VIP

    Joined:
    Nov 3, 2013
    Messages:
    2,865
    Likes Received:
    6,978
    Gender:
    Male
    Occupation:
    Traveling the world
    Location:
    Berlin
    It has nothing to do with proxies dude. I'm currently botting only 2 accounts on my personal PC and home IP and still getting this error.
     
  13. onelettershor

    onelettershor Supreme Member

    Joined:
    Aug 4, 2015
    Messages:
    1,302
    Likes Received:
    447
    Gender:
    Female
    Location:
    Land of sheep
    FL is pretty buggy, I heard the support doesn't do much about it.

    OP I would PM weblue on this site.