1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[UBOT] - WordPress Comment Poster - Problem

Discussion in 'Other Scripting Languages' started by red1eaf, Jan 9, 2012.

  1. red1eaf

    red1eaf Registered Member

    Joined:
    Oct 3, 2008
    Messages:
    78
    Likes Received:
    28
    HI UBOT coding experts,

    I have been trying for last couple of days to write a ubot script to post comments to a set of wordpress blog posts.

    I have tried it on my own blog and seems to have been struck at a specific point.

    Attached is the simplified version of the bot.

    1) It takes Name,Email,Comment as inputs from the user
    2) Navigates to the given blog post ( hardcoded)
    2) Fill the comment form on the wordpress blog
    3) submit the comment

    The problem is that , after i click on the submit button , the below page loads and throws a 404 error.

    Code:
    http://www.yogacommons.com/wp-comments-post.php
    i am using one of my own sample blog posts to test this bot and everytime i seem to hit the same problem .

    here is the sample blog post url

    Code:
    http://yogacommons.com/what-would-be-your-first-impression-of-a-girl-who-wears-yoga-pants-to-school/
    Can someone help me with this simple script. ( Bot attached in this post)
     

    Attached Files:

  2. red1eaf

    red1eaf Registered Member

    Joined:
    Oct 3, 2008
    Messages:
    78
    Likes Received:
    28
    no UBOT experts here ???
     
  3. meatro

    meatro BANNED BANNED

    Joined:
    Nov 21, 2009
    Messages:
    568
    Likes Received:
    997
    Works just fine on my end.. UBot 4 Pro.

    avc says:
    Your comment is awaiting moderation.
    January 9, 2012 at 6:17 pm
    anything
    Reply

    (Cool thing I learned from this, though.. You can open UBot files with WinRAR and get the source code.)
     
    • Thanks Thanks x 1
  4. red1eaf

    red1eaf Registered Member

    Joined:
    Oct 3, 2008
    Messages:
    78
    Likes Received:
    28
    thanks a lot for the response.. looks like something is wrong on my system....

    i will check and post the results back.. if working.. i will release it to the BHW free..
     
  5. red1eaf

    red1eaf Registered Member

    Joined:
    Oct 3, 2008
    Messages:
    78
    Likes Received:
    28
    bot doesnt seem to work with proxies .. Also, it starts throwing 404 errror intermittently. I think its an internal Wordpress protection mechanism.. when too many comments are being thrown at it. '

    not really sure..

    I will put some delay parameter into the loop.