Subdomain is not getting indexed in google!

Discussion in 'Black Hat SEO' started by Desert90, May 30, 2015.

  1. Desert90

    Desert90 Senior Member

    Joined:
    Sep 23, 2012
    Messages:
    973
    Likes Received:
    141
    Location:
    BHW
    I have an amazon niche site and a subdomain is not getting indexed. I submitted it many times to google but google is not indexing it.
    What can i do ? But i am sure its not disallowed at robots file. What can be the problem ?

    My second question: another subdomain on a niche site for mobile offers is on 29 google germany. What can i do to rank it to page 1 ?
    What will be the best seo ?
     
  2. Rotem Guez

    Rotem Guez BANNED BANNED

    Joined:
    Jul 15, 2010
    Messages:
    728
    Likes Received:
    1,260
    1. You can PM me the URL and i'll check it for you.
    2. Big question. It's like asking how to make a lot of $$$.
     
  3. Desert90

    Desert90 Senior Member

    Joined:
    Sep 23, 2012
    Messages:
    973
    Likes Received:
    141
    Location:
    BHW
    Thanks! Just sent you a pm
     
  4. hidedora

    hidedora Regular Member

    Joined:
    Sep 21, 2011
    Messages:
    213
    Likes Received:
    35
    If it's possible, send me the uri of your site as well. Did you check if it has no index, nofollow tags within the html code? I'd like to give it a detailed look if you don't mind. Did you created it recently perhaps? I would also do some bookmarks on it in order to get it indexed faster.
     
  5. hidedora

    hidedora Regular Member

    Joined:
    Sep 21, 2011
    Messages:
    213
    Likes Received:
    35
    Hey mate, thanks for sending me the URI. After checking your website, I found that it has a noindex attribute in the head of the site. I would suggest you to remove entirely the

    <meta name="robots" content="noindex,follow" />
    This is what causes the problem probably. I hope this helps! Cheers!
     
    • Thanks Thanks x 1
  6. Desert90

    Desert90 Senior Member

    Joined:
    Sep 23, 2012
    Messages:
    973
    Likes Received:
    141
    Location:
    BHW
    Thanks for helping! I just saw on my seo plugin that it added noindex attribute to categories.
    i unchecked option now, i think its working now