1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Stupid facebook does not show images when posting link to video

Discussion in 'FaceBook' started by Chicilikit, Mar 13, 2013.

  1. Chicilikit

    Chicilikit Senior Member

    Joined:
    Dec 21, 2010
    Messages:
    875
    Likes Received:
    153
    Hello, i have really big problem with facebook not showing image thumbnail of link leading to youtube video on my blogger blog. Anyone who had similar problem and found solution? Thanks for any help.
     
  2. xashishx

    xashishx Regular Member

    Joined:
    Jan 30, 2011
    Messages:
    420
    Likes Received:
    125
    Occupation:
    Internet Marketer
    Location:
    India
    Youtube video or your blogger link? If your blogger link was already used on facebook, maybe the link is not updated on facebook.

    Go to facebook debugger and debug your link, check if all tags are good.
     
  3. Chicilikit

    Chicilikit Senior Member

    Joined:
    Dec 21, 2010
    Messages:
    875
    Likes Received:
    153
    Yeah its youtube embedded video at blogger, tried debugger, it does not work, tried google shortener which should work, but it does not work either.
     
  4. xashishx

    xashishx Regular Member

    Joined:
    Jan 30, 2011
    Messages:
    420
    Likes Received:
    125
    Occupation:
    Internet Marketer
    Location:
    India
    A video thumbnail is only shown for a regular video page. A blogger doesn't work that way, atleast, I have never seen any.