1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Sorry if this is the wrong section, just a quick question.

Discussion in 'Black Hat SEO' started by charbel, Jun 19, 2014.

  1. charbel

    charbel Jr. VIP Jr. VIP Premium Member

    Joined:
    Feb 19, 2012
    Messages:
    839
    Likes Received:
    285
    Home Page:
    Google won't index my new meta title's, nor the description on a website i have. It's been the same for about 5 days and everyday i submit them to Index through GWT, I understand giving Google time to crawl your new content but i think it's been taking too long, anyone have any tips? I have a sitemap.
     
  2. tony_d

    tony_d Elite Member

    Joined:
    Jun 22, 2013
    Messages:
    2,581
    Likes Received:
    3,163
    Location:
    1600 Amphitheatre Parkway, Mountain View CA
    Build a few links... even from wordpress 2.0's. It'll crawl out from there pretty quickly.
     
    • Thanks Thanks x 1
  3. charbel

    charbel Jr. VIP Jr. VIP Premium Member

    Joined:
    Feb 19, 2012
    Messages:
    839
    Likes Received:
    285
    Home Page:
    Thanks mate, will give this a try!
     
  4. Agnes Bogdanova

    Agnes Bogdanova Regular Member

    Joined:
    Mar 20, 2014
    Messages:
    222
    Likes Received:
    26
    Location:
    united kingdom
    Home Page:
    Try this, it really helps getting indexed
    secure.profitinstruments.com/quickindex/
     
    • Thanks Thanks x 1