1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Sites main KW search not showing up in google? WTF?

Discussion in 'BlackHat Lounge' started by OldFatGuy, Aug 8, 2011.

  1. OldFatGuy

    OldFatGuy Regular Member

    Joined:
    Jun 4, 2009
    Messages:
    253
    Likes Received:
    149
    I have a site with a highly competitive 2 word keyword phrase followed by another word... eg: internetmarketingworld.com (not mine and not the niche etc.)

    Webmaster tools says it's in the average position of 170... but when I search for the 2 word phrase (eg: internet marketing), it's not to be found anywhere. However, if I search for the full site name internetmarketingworld or internet marketing world, I'm #1.. And I have a number of pages on the site ranking in the top 10 with several #1.

    What the hell is going on with that?
     
  2. Autumn

    Autumn Elite Member

    Joined:
    Nov 18, 2010
    Messages:
    2,197
    Likes Received:
    3,041
    Occupation:
    I figure out ways to make money online and then au
    Location:
    Spamville
    Your site is competitive enough (including the EMD effect) to rank for internet marketing world, but it's not competitive enough to rank for internet marketing. You will have to do more work to rank for internet marketing, specifically getting good quality links with the right anchor text ("internet marketing").

    Often the main keyphrase in a niche is significantly more competitive than the longer tails.
     
  3. OldFatGuy

    OldFatGuy Regular Member

    Joined:
    Jun 4, 2009
    Messages:
    253
    Likes Received:
    149
    Yeah, I get that... But what I don't get is why the site doesn't show up at all in the SERPs as if it hasn't even been indexed... Used scroogle as well to double check, and like I said, google's WM tools say it's supposed to be around 170..
     
  4. Autumn

    Autumn Elite Member

    Joined:
    Nov 18, 2010
    Messages:
    2,197
    Likes Received:
    3,041
    Occupation:
    I figure out ways to make money online and then au
    Location:
    Spamville
    Have you checked multiple data centres? Cookies? Local results? ISP caching?
     
  5. OldFatGuy

    OldFatGuy Regular Member

    Joined:
    Jun 4, 2009
    Messages:
    253
    Likes Received:
    149
    Yep, I tried a bunch of different things... Nada.. Just weird..