1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Removing archive menu from side bar in wordpress?

Discussion in 'White Hat SEO' started by darkman, May 8, 2012.

  1. darkman

    darkman Regular Member

    Joined:
    Jan 17, 2009
    Messages:
    454
    Likes Received:
    264
    Hi guys,
    How do i remove archive menu on the side bar?
    I don't want it to show archive with month display under it because i am not planning to add more post to it.
    I can't remove it through "widget".
    Thanks.
     
  2. TZ2011

    TZ2011 Senior Member

    Joined:
    Jun 26, 2011
    Messages:
    832
    Likes Received:
    863
    Occupation:
    Cleaning servers
    How you mean you can't remove it from widget zone ? It is hardcoded ? Which template you use ?
     
  3. -Jericho-

    -Jericho- Jr. Executive VIP Jr. VIP Premium Member

    Joined:
    Jan 10, 2010
    Messages:
    2,849
    Likes Received:
    1,704
    Location:
    Stalking My Ex-Wife
    If it's hardcoded try editing the sidebar.php file. Is theme widget enabled?
     
  4. darkman

    darkman Regular Member

    Joined:
    Jan 17, 2009
    Messages:
    454
    Likes Received:
    264
    i use a free template from siteground hosting.
    the name of the template is siteground-wp23 1.0
     
  5. darkman

    darkman Regular Member

    Joined:
    Jan 17, 2009
    Messages:
    454
    Likes Received:
    264
    sorry i dont know the meaning of hardcoded.
    in widget menu , under sidebar there are only links and meta link, the archive link is disabled on the left but somehow it is still showing.
     
  6. darkman

    darkman Regular Member

    Joined:
    Jan 17, 2009
    Messages:
    454
    Likes Received:
    264
    in the editor for sidebar.php i see below script :
    Should i just delete a few lines? which one is it?


    <div id="sidebar">
    <ul>

    <?php wp_list_pages('title_li=<h2>Pages</h2>' ); ?>

    <li><h2>Archives</h2>
    <ul>
    <?php wp_get_archives('type=monthly'); ?>
    </ul>
    </li>

    <?php wp_list_categories('show_count=1&title_li=<h2>Categories</h2>'); ?>

    <?php if ( is_home() || is_page() ) { ?>
    <?php wp_list_bookmarks(); ?>

    <li><h2>Meta</h2>
    <ul>
    <?php wp_register(); ?>
    <li><?php wp_loginout(); ?></li>
    <li><a href="http://wordpress.org/" title="Powered by WordPress, state-of-the-art semantic personal publishing platform.">WordPress</a></li>
    <?php wp_meta(); ?>
    </ul>
    </li>
    <?php } ?>

    </ul>
    <? $sg = 'banner'; include "templates.php";?>
    </div>
     
  7. darkman

    darkman Regular Member

    Joined:
    Jan 17, 2009
    Messages:
    454
    Likes Received:
    264
    anyone can help me?
     
  8. milian

    milian Power Member

    Joined:
    Jan 9, 2010
    Messages:
    515
    Likes Received:
    69
    Occupation:
    SEO stuff
    Location:
    Around
    try deleting this:

    <li><h2>Archives</h2>
    <ul>
    <?php wp_get_archives('type=monthly'); ?>
    </ul>
    </li>

    (make a back up first in case it messes something up)
     
    • Thanks Thanks x 1