1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Question from IMACROS user

Discussion in 'Black Hat SEO' started by tabish8612, Feb 2, 2010.

  1. tabish8612

    tabish8612 Power Member

    Joined:
    Sep 13, 2009
    Messages:
    504
    Likes Received:
    109
    Occupation:
    Online Marketing
    Location:
    In your home...COMPUTER
    hello everyone,
    I have a question for Imacro user. When I write this code
    Code:
    TAB T=1
    URL GOTO=http://buddymarks.com/signup.php?sc=homepage     
    CMDLINE !DATASOURCE Bookmark.txt
    TAG POS=1 TYPE=INPUT:TEXT FORM=ACTION:/signup.php?final ATTR=NAME:username CONTENT={{Username}} 
    TAG POS=1 TYPE=INPUT:PASSWORD FORM=ACTION:/signup.php?final ATTR=NAME:password CONTENT={{Pass1}} 
    TAG POS=1 TYPE=INPUT:PASSWORD FORM=ACTION:/signup.php?final ATTR=NAME:password_verify CONTENT={{Pass1}} 
    It is show enter "__undefined__" in all textbox in firefox imacros but when I give same code to IMACROS scripting version it will give correct value. So what should I use so that it give correct value in firefox
     
  2. mrwho

    mrwho Junior Member

    Joined:
    Apr 3, 2008
    Messages:
    122
    Likes Received:
    39
    It seems like your imacro is missing this bit of code:
    Code:
    SET !DATASOURCE_COLUMNS 3
    SET !LOOP 2
    SET !DATASOURCE_LINE {{!LOOP}
    If that's not it make sure Bookmark.txt is in the datasource folder. Imacro firefox and Imacro Scripting edition use separate folders, at least mine do.
    Imacro firefox is in "My documents" and Imacro SE is in "Documents"